<!DOCTYPE html><html lang="en-US" itemscope="" itemtype="https://schema.org/BlogPosting" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"><head><meta charset="utf-8" />
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function AddAndFireOrigPixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0,true);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id,isOrig){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
if(typeof isOrig==='undefined'){isOrig=false;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot,isOrig);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){if((impId!=="0"||isOrig===true)&&adUnit!==""){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig,});}}}
function AddPixelById(impFullId,pixelData,isOrig){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig});}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){var allPixels=[pixels.filter(function(pixel){return pixel.is_orig}),pixels.filter(function(pixel){return!pixel.is_orig})];allPixels.forEach(function(pixels){while(pixels.length>0){var isOrig=pixels[0].is_orig||false;var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pushPixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
__ez.dot.Fire(pixelURL);}})}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddAndFireOrig:AddAndFireOrigPixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();__ez.queue.addFile('/detroitchicago/raleigh.js', '//g.ezoic.net/detroitchicago/raleigh.js?gcb=195-3&cb=5', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '//g.ezoic.net/detroitchicago/tampa.js?gcb=195-3&cb=4', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '//g.ezoic.net/detroitchicago/tulsa.js?gcb=195-3&cb=5', false, [], true, false, true, false);</script>
<title>Cyber attacks on Russia by Ukrainian IT army &amp; Anonymous | Euromaidan Press</title>

<meta name="facebook-domain-verification" content="y3lg7zz0w20jmh7dydfiqiqsp3obhy" />
<meta name="google-site-verification" content="4VvkhMMEFReuAiV5fbtYmHh9_EmxyzRCSznz7holy0U" />







<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1" />
<link href="//fonts.googleapis.com/css?family=Roboto+Slab:700|Roboto+Slab:700|Roboto+Slab:300|Roboto+Slab:400|Roboto+Slab:700|Roboto+Slab:300|Roboto+Slab:400|Roboto+Slab:300|Open+Sans:300" rel="stylesheet" data="test" />
<meta name="robots" content="index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1" />

<meta name="description" content="The Minister of Digital Transformation of Ukraine Mychaylo Fedorov, who previously launched IT Army of Ukraine on 26 February" />
<link rel="canonical" href="https://euromaidanpress.com/2022/03/04/international-cyberoffensive-gives-russia-a-sip-of-its-own-bitter-medicine/" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:title" content="Cyber attacks on Russia by Ukrainian IT army &amp; Anonymous" />
<meta name="twitter:description" content="The Minister of Digital Transformation of Ukraine Mychaylo Fedorov, who previously launched IT Army of Ukraine on 26 February" />
<meta name="twitter:image" content="https://euromaidanpress.com/wp-content/uploads/2022/03/word-image-18.png" />
<meta name="twitter:creator" content="@euromaidanpress" />
<meta name="twitter:site" content="@euromaidanpress" />
<script type="application/ld+json" class="yoast-schema-graph">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</script>

<link rel="dns-prefetch" href="//connect.facebook.net" />
<link rel="dns-prefetch" href="//static2.euromaidanpress.com" />
<link rel="dns-prefetch" href="//static.euromaidanpress.com" />
<link rel="dns-prefetch" href="//connect.facebook.net" />
<link rel="alternate" type="application/rss+xml" title="Euromaidan Press » Feed" href="https://euromaidanpress.com/feed/" />
<link rel="stylesheet" id="simple_tooltips_style-css" href="https://static2.euromaidanpress.com/wp-content/plugins/simple-tooltips/zebra_tooltips.css?ver=ac2732b0918a4eecf73796ab1bfda806" media="all" />
<link rel="stylesheet" id="aqpb-view-css-css" href="https://static.euromaidanpress.com/wp-content/themes/superblog/functions/aqua/assets/css/aqpb-view.css?ver=ac2732b0918a4eecf73796ab1bfda806" media="all" />
<link rel="stylesheet" id="rtoc_style-css" href="https://static2.euromaidanpress.com/wp-content/plugins/rich-table-of-content/css/rtoc_style.css?ver=ac2732b0918a4eecf73796ab1bfda806" media="all" />
<link rel="stylesheet" id="mediaelement-css" href="https://euromaidanpress.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16" media="all" />
<link rel="stylesheet" id="wp-mediaelement-css" href="https://euromaidanpress.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=ac2732b0918a4eecf73796ab1bfda806" media="all" />
<style id="global-styles-inline-css">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</style>
<link rel="stylesheet" id="fontawesome-css" href="https://static2.euromaidanpress.com/wp-content/plugins/olevmedia-shortcodes/assets/css/font-awesome.min.css?ver=ac2732b0918a4eecf73796ab1bfda806" media="all" />
<link rel="stylesheet" id="omsc-shortcodes-css" href="https://static2.euromaidanpress.com/wp-content/plugins/olevmedia-shortcodes/assets/css/shortcodes.css?ver=ac2732b0918a4eecf73796ab1bfda806" media="all" />
<link rel="stylesheet" id="omsc-shortcodes-tablet-css" href="https://static2.euromaidanpress.com/wp-content/plugins/olevmedia-shortcodes/assets/css/shortcodes-tablet.css?ver=ac2732b0918a4eecf73796ab1bfda806" media="screen and (min-width: 768px) and (max-width: 959px)" />
<link rel="stylesheet" id="omsc-shortcodes-mobile-css" href="https://static2.euromaidanpress.com/wp-content/plugins/olevmedia-shortcodes/assets/css/shortcodes-mobile.css?ver=ac2732b0918a4eecf73796ab1bfda806" media="screen and (max-width: 767px)" />
<link rel="stylesheet" id="ppress-frontend-css" href="https://static2.euromaidanpress.com/wp-content/plugins/wp-user-avatar/assets/css/frontend.min.css?ver=3.2.8" media="all" />
<link rel="stylesheet" id="ppress-flatpickr-css" href="https://static2.euromaidanpress.com/wp-content/plugins/wp-user-avatar/assets/flatpickr/flatpickr.min.css?ver=3.2.8" media="all" />
<link rel="stylesheet" id="ppress-select2-css" href="https://static2.euromaidanpress.com/wp-content/plugins/wp-user-avatar/assets/select2/select2.min.css?ver=ac2732b0918a4eecf73796ab1bfda806" media="all" />
<link rel="stylesheet" id="bcct_style-css" href="https://static2.euromaidanpress.com/wp-content/plugins/better-click-to-tweet/assets/css/styles.css?ver=3.0" media="all" />
<link rel="stylesheet" id="pc_google_analytics-frontend-css" href="https://static2.euromaidanpress.com/wp-content/plugins/pc-google-analytics/assets/css/frontend.css?ver=1.0.0" media="all" />
<link rel="stylesheet" id="wpProQuiz_front_style-css" href="https://static2.euromaidanpress.com/wp-content/plugins/wp-pro-quiz/css/wpProQuiz_front.min.css?ver=0.37" media="all" />
<link rel="stylesheet" id="wppopups-base-css" href="https://static2.euromaidanpress.com/wp-content/plugins/wp-popups-lite/src/assets/css/wppopups-base.css?ver=2.1.4.5" media="all" />
<link rel="stylesheet" id="default_style-css" href="https://static.euromaidanpress.com/wp-content/themes/superblog/style.css?ver=1643722626" media="all" />
<link rel="stylesheet" id="layout-css" href="https://static.euromaidanpress.com/wp-content/themes/superblog/style-layout.css?ver=ac2732b0918a4eecf73796ab1bfda806" media="all" />
<link rel="stylesheet" id="prettyPhoto-css" href="https://static.euromaidanpress.com/wp-content/themes/superblog/styles/prettyPhoto.css?ver=ac2732b0918a4eecf73796ab1bfda806" media="all" />
<link rel="stylesheet" id="shortcodes-css" href="https://static.euromaidanpress.com/wp-content/themes/superblog/functions/css/shortcodes.css?ver=ac2732b0918a4eecf73796ab1bfda806" media="all" />
<link rel="stylesheet" id="social-media-css" href="https://static.euromaidanpress.com/wp-content/themes/superblog/styles/social-media.css?ver=ac2732b0918a4eecf73796ab1bfda806" media="all" />
<link rel="stylesheet" id="font-awesome.min-css" href="https://static.euromaidanpress.com/wp-content/themes/superblog/styles/font-awesome.min.css?ver=ac2732b0918a4eecf73796ab1bfda806" media="all" />
<link rel="stylesheet" id="style-custom-css" href="https://static.euromaidanpress.com/wp-content/themes/superblog/style-custom.css?ver=ac2732b0918a4eecf73796ab1bfda806" media="all" />
<link rel="stylesheet" id="woo-custom-css" href="https://static.euromaidanpress.com/wp-content/themes/superblog/styles/woo-custom.css?ver=ac2732b0918a4eecf73796ab1bfda806" media="all" />
<link rel="stylesheet" id="mobile-css" href="https://static.euromaidanpress.com/wp-content/themes/superblog/style-mobile.css?ver=1640696521" media="all" />
<link rel="stylesheet" id="metro_style_social_widget-css" href="https://static2.euromaidanpress.com/wp-content/plugins/metro-style-social-widget/CSS/metro.css?ver=ac2732b0918a4eecf73796ab1bfda806" media="all" />
<link rel="stylesheet" id="slb_core-css" href="https://static2.euromaidanpress.com/wp-content/plugins/simple-lightbox/client/css/app.css?ver=2.8.1" media="all" />
<link rel="stylesheet" id="tablepress-default-css" href="https://static.euromaidanpress.com/wp-content/uploads/tablepress-combined.min.css?ver=37" media="all" />
<link rel="stylesheet" id="fancybox-css" href="https://static2.euromaidanpress.com/wp-content/plugins/easy-fancybox/css/jquery.fancybox.min.css?ver=1.3.24" media="screen" />
<link rel="stylesheet" id="msl-main-css" href="https://static2.euromaidanpress.com/wp-content/plugins/master-slider/public/assets/css/masterslider.main.css?ver=3.8.1" media="all" />
<link rel="stylesheet" id="msl-custom-css" href="https://static.euromaidanpress.com/wp-content/uploads/master-slider/custom.css?ver=35.5" media="all" />
<link rel="stylesheet" id="__EPYT__style-css" href="https://static2.euromaidanpress.com/wp-content/plugins/youtube-embed-plus/styles/ytprefs.min.css?ver=14.0.1.4" media="all" />
<style id="__EPYT__style-inline-css">

                .epyt-gallery-thumb {
                        width: 33.333%;
                }
                
</style>
<link rel="stylesheet" id="social-logos-css" href="https://static2.euromaidanpress.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=10.7" media="all" />
<link rel="stylesheet" id="jetpack_css-css" href="https://static2.euromaidanpress.com/wp-content/plugins/jetpack/css/jetpack.css?ver=10.7" media="all" />
<script src="https://euromaidanpress.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0" id="jquery-core-js"></script>
<script src="https://euromaidanpress.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2" id="jquery-migrate-js"></script>
<script id="jetpack_related-posts-js-extra">
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"b"};
/* ]]> */
</script>
<script src="https://static2.euromaidanpress.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20211209" id="jetpack_related-posts-js"></script>
<script src="https://static2.euromaidanpress.com/wp-content/plugins/wp-user-avatar/assets/flatpickr/flatpickr.min.js?ver=ac2732b0918a4eecf73796ab1bfda806" id="ppress-flatpickr-js"></script>
<script src="https://static2.euromaidanpress.com/wp-content/plugins/wp-user-avatar/assets/select2/select2.min.js?ver=ac2732b0918a4eecf73796ab1bfda806" id="ppress-select2-js"></script>
<script src="https://static2.euromaidanpress.com/wp-content/plugins/pc-google-analytics/assets/js/frontend.min.js?ver=1.0.0" id="pc_google_analytics-frontend-js"></script>
<script id="__ytprefs__-js-extra">
/* <![CDATA[ */
var _EPYT_ = {"ajaxurl":"https:\/\/euromaidanpress.com\/wp-admin\/admin-ajax.php","security":"54186cbb24","gallery_scrolloffset":"20","eppathtoscripts":"https:\/\/static2.euromaidanpress.com\/wp-content\/plugins\/youtube-embed-plus\/scripts\/","eppath":"https:\/\/static2.euromaidanpress.com\/wp-content\/plugins\/youtube-embed-plus\/","epresponsiveselector":"[\"iframe.__youtube_prefs__\",\"iframe[src*='youtube.com']\",\"iframe[src*='youtube-nocookie.com']\",\"iframe[data-ep-src*='youtube.com']\",\"iframe[data-ep-src*='youtube-nocookie.com']\",\"iframe[data-ep-gallerysrc*='youtube.com']\"]","epdovol":"1","version":"14.0.1.4","evselector":"iframe.__youtube_prefs__[src], iframe[src*=\"youtube.com\/embed\/\"], iframe[src*=\"youtube-nocookie.com\/embed\/\"]","ajax_compat":"","ytapi_load":"light","pause_others":"","stopMobileBuffer":"1","vi_active":"","vi_js_posttypes":[]};
/* ]]> */
</script>
<script defer="" src="https://static2.euromaidanpress.com/wp-content/plugins/youtube-embed-plus/scripts/ytprefs.min.js?ver=14.0.1.4" id="__ytprefs__-js"></script>

<meta property="og:image" content="https://euromaidanpress.com/wp-content/uploads/2022/03/word-image-18.png" /><meta property="og:image:secure_url" content="https://static.euromaidanpress.com/wp-content/uploads/2022/03/word-image-18.png" /><meta property="og:image:width" content="977" /><meta property="og:image:height" content="650" /><meta property="og:image:alt" content="International cyberoffensive gives Russia “a sip of its own bitter medicine”" /><meta property="og:image:type" content="image/png" /><meta property="og:image" content="http://img.youtube.com/vi/31OIdBg91WI/hqdefault.jpg" /><meta property="og:image:secure_url" content="https://img.youtube.com/vi/31OIdBg91WI/hqdefault.jpg" /><meta property="og:image:width" content="480" /><meta property="og:image:height" content="360" /><meta property="og:image:type" content="image/jpeg" /><meta property="og:video" content="https://youtu.be/31OIdBg91WI" /><meta property="og:description" content="On 1 March 2022, the Minister of Digital Transformation of Ukraine Mychaylo Fedorov, who previously launched the IT Army of Ukraine, wrote: “If in the beginning we constrained many powerful cyberattacks, mainly due to the long preparation of Russia in advance, now, thanks to the common spirit of Ukrainians for freedom, we have moved to..." /><meta property="og:type" content="article" /><meta property="og:locale" content="en_US" /><meta property="og:site_name" content="Euromaidan Press" /><meta property="og:title" content="International cyberoffensive gives Russia “a sip of its own bitter medicine”" /><meta property="og:url" content="https://euromaidanpress.com/2022/03/04/international-cyberoffensive-gives-russia-a-sip-of-its-own-bitter-medicine/" /><meta property="og:updated_time" content="2022-03-04T15:20:28+02:00" />
<meta property="article:tag" content="cyber attacks" /><meta property="article:tag" content="cybersecurity" /><meta property="article:tag" content="cyberwar" /><meta property="article:published_time" content="2022-03-04T12:51:26+00:00" /><meta property="article:modified_time" content="2022-03-04T13:20:28+00:00" /><meta property="article:section" content="International" /><meta property="article:section" content="Russian Aggression" /><meta property="article:author:first_name" content="Orysia" /><meta property="article:author:last_name" content="Hrudka" /><meta property="article:author:username" content="Orysia Hrudka" />
<meta property="twitter:partner" content="ogwp" /><meta property="twitter:player" content="https://youtu.be/31OIdBg91WI" /><meta property="twitter:card" content="summary_large_image" /><meta property="twitter:image" content="https://static.euromaidanpress.com/wp-content/uploads/2022/03/word-image-18.png" /><meta property="twitter:image:alt" content="International cyberoffensive gives Russia “a sip of its own bitter medicine”" /><meta property="twitter:title" content="International cyberoffensive gives Russia “a sip of its own bitter medicine”" /><meta property="twitter:description" content="On 1 March 2022, the Minister of Digital Transformation of Ukraine Mychaylo Fedorov, who previously launched the IT Army of Ukraine, wrote: “If in the beginning we constrained many powerful..." /><meta property="twitter:url" content="https://euromaidanpress.com/2022/03/04/international-cyberoffensive-gives-russia-a-sip-of-its-own-bitter-medicine/" />
<meta itemprop="image" content="https://static.euromaidanpress.com/wp-content/uploads/2022/03/word-image-18.png" /><meta itemprop="name" content="International cyberoffensive gives Russia “a sip of its own bitter medicine”" /><meta itemprop="headline" content="International cyberoffensive gives Russia “a sip of its own bitter medicine”" /><meta itemprop="description" content="On 1 March 2022, the Minister of Digital Transformation of Ukraine Mychaylo Fedorov, who previously launched the IT Army of Ukraine, wrote: “If in the beginning we constrained many powerful cyberattacks, mainly due to the long preparation of Russia in advance, now, thanks to the common spirit of Ukrainians for freedom, we have moved to..." /><meta itemprop="datePublished" content="2022-03-04" /><meta itemprop="dateModified" content="2022-03-04T13:20:28+00:00" /><meta itemprop="author" content="Orysia Hrudka" />
<meta property="profile:first_name" content="Orysia" /><meta property="profile:last_name" content="Hrudka" /><meta property="profile:username" content="Orysia Hrudka" />

<link rel="https://api.w.org/" href="https://euromaidanpress.com/wp-json/" /><link rel="alternate" type="application/json" href="https://euromaidanpress.com/wp-json/wp/v2/posts/160604" /><link rel="alternate" type="application/json+oembed" href="https://euromaidanpress.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Feuromaidanpress.com%2F2022%2F03%2F04%2Finternational-cyberoffensive-gives-russia-a-sip-of-its-own-bitter-medicine%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://euromaidanpress.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Feuromaidanpress.com%2F2022%2F03%2F04%2Finternational-cyberoffensive-gives-russia-a-sip-of-its-own-bitter-medicine%2F&amp;format=xml" />
<style>
#donations_progress_bar{ width:60%; background:white; margin:auto; position: relative; height: 24px; }
#donate_top_panel .button{
        display: block; float: right; background: yellow; color: #c40123; padding: 10px; vertical-align: middle; font-weight: bold; margin-right:10px;
	}

#pledged{border:2px solid #05acfa; width: 100%; margin:auto;height:5px; overflow:hidden; height: 24px}
#have{background: #05acfa !important;float:left;}

#text_pledged{color:#000 !important; font-size: 22px; float:left; display:block}
#text_out_of{color:#303030 !important; float:right; display:block}

#donations_progress_bar p{position:absolute; top: 2px; left:2px; width:99%}

/*tmp*/
#text_out_of{display:none}
#text_pledged{width:100%;text-align:center;float:none;color:white !important;padding:10px}
#donations_progress_bar{height:auto; vertical-align:middle;width:80%;
overflow:hidden;
-webkit-border-top-left-radius: 1em;
-webkit-border-bottom-left-radius: 1em;
-moz-border-radius-topleft: 1em;
-moz-border-radius-bottomleft: 1em;
border-top-left-radius: 1em;
border-bottom-left-radius: 1em;
}
#donations_progress_bar{background:#511721;height:48px;width:420px}
#pledged{background:#511721;height:48px;border:0}
#have{height:48px; background: #00a3df url(/wp-content/pledge-bg.png) !important;float:left}
/*fixes*/
#navigation_wrap{margin-bottom:15px !important}
#core{margin-top:15px !important}

@media (max-width:1024px){
	#donations_progress_bar{width:300px}
}
@media (max-width:749px){
	#donate_top_panel table, #donate_top_panel, #donate_top_panel tr, #donate_top_panel td{
		
		display:block!important;
		width:100%!important;
		max-width:100%!important;
		margin:0!important;
		text-align:center;
		padding-left:0!important;
		padding-right:0!important;
		}
	#donate_top_panel .button{display:block;margin:0 auto 10px auto !important;float:none!important;width:50%}
	#donate_top_panel td b a{width:100%!important}
	#donations_progress_bar{width:90%;margin:auto}
	#donate_top_panel *{max-width:100%}
	tbody, tr{display:inline-block}
}

</style>
<script>var ms_grabbing_curosr = 'https://static2.euromaidanpress.com/wp-content/plugins/master-slider/public/assets/css/common/grabbing.cur', ms_grab_curosr = 'https://static2.euromaidanpress.com/wp-content/plugins/master-slider/public/assets/css/common/grab.cur';</script>
<script>
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
		
		ga('create', 'UA-30994008-2', 'auto');
		ga('send', 'pageview');
		
		</script>
<script src="//euromaidanpress.com/?wordfence_syncAttackData=1646406938.7434" async=""></script>

<meta property="og:image" content="https://euromaidanpress.com/wp-content/uploads/2022/03/word-image-18.png" />


<style>img#wpstats{display:none}</style>
<link rel="shortcut icon" href="/wp-content/uploads/2015/01/favicon.png" />

<link href="https://static.euromaidanpress.com/wp-content/themes/superblog/functions/css/shortcodes.css" rel="stylesheet" />

<style>

	#header,#navigation,.nav li ul,ul.social-menu .social-menu-more li,.flexcarousel ul.slides li,#hometab,.postinfo,.widgetable,ul.products li.product {background-color:#ffffff}

	.nav>li>ul:after{border-color:#ffffff transparent}

	#main-nav>li>a,.searchform,ul.social-menu li{border-color:#ffffff !important}

	.woocommerce-message,.woocommerce-error,.woocommerce-info{background:#ffffff !important}

	#footer,.body2,.h2.widget_spec,h2.widget_spec,.imgwrap,#topnav,.maso,.mainflex .videoinside{background-color:#000000}

	.socialtrigger a:hover,.socialtrigger a.active,.overrating,.meta_more a:hover,.sf-sub-indicator,span.score,.flexslider a.flex-prev,.flexslider a.flex-next,.ratingbar,#sidebar p input[type=submit],span.ribbon,a#triggernav,a#triggernav-sec,a.fromhome,a.mainbutton,a.itembutton,.page-numbers.current,a.comment-reply-link,#submit,#comments .navigation a,.tagssingle a,.contact-form .submit,.intro,li.main .h2, li.main h2,.plan-bottom a,.scrollTo_top a,.gallery-item, submit{background-color:#05acfa}
h3 a i,h4 a i,#core .meta_more a,#content .meta_more a,a.moreposts,.more a.fr,#content .entry a,li ul li.current-menu-item a,#core a.add_to_cart_button{color:#05acfa}
.h2.widget, h2.widget, .h2.widget_spec, h2.widget_spec,.meta_more a,#serinfo-nav li.current a,.woocommerce a.button{border-color:#05acfa !important}
#main-nav>li>a:hover,#main-nav>li.current-menu-ancestor>a,#main-nav>li.current-menu-item>a,#main-nav>li.sfHover>a,#main-nav>li.current_page_item>a,#main-nav>li.current-menu-item>a,.page-numbers.current,.woocommerce a.button:hover{background-color:#05acfa !important}

	body,#navigation,.social-menu-more{background-color:#ffffff}

	.body1 a, a:link, a:visited,.nav li ul li a{color:#000000}

	span>a.moreposts,ul#serinfo-nav li a{color:#000000 !important}

	a:hover,.body1 a:hover{color:#292929  !important}

	#sec-nav > li > a,#footer a {color:#fff}

	.body2 a:hover,p.body2 a:hover,#sec-nav > li > a:hover{color:#ccc !important}

	.woocommerce ul.products,#navigation,#header,.aq-block,.fblock,ul#serinfo,.postinfo,.postinfo span,.widgetable,.related,#hometab,.h2.leading, h2.leading,.postauthor_alt{border-color:#e6e6e6 !important}

	body,input, textarea,input checkbox,input radio,select, file,h3.sd-title {font:400 16px/1.8em Roboto Slab;color:#545454}

	.body2,#footer,.searchformhead>input.s {font:300 15px/1.8em Roboto Slab;color:#ffffff}

	.ratingblock .h2, .ratingblock h2,.ratingblock .h3, .ratingblock h3,.ratingblock p,#footer .h2, #footer h2,.body2 .h2, .body2 h2,.body2 .h3, .body2 h3{color:#ffffff}
	.intro .h1, .intro .h1 a, .intro h1,.intro h1 a,a.itembutton,a.mainbutton,.page-numbers.current{color:}

	.h1, .h2.post,h1,h2.post {font:700 55px/1.0em Roboto Slab;color:#000000}
	.h2.widget, h2.widget,.meta_more a,a.morebutton,ul#serinfo-nav li a {font:300 16px/1.2em Roboto Slab;color:#000000}
	.h2, h2 {font:700 30px/1.2em Roboto Slab;color:#6b6b6b}
	.h3, .h3#reply-title, h3,h3#reply-title, #respond .h3, #respond h3,.comment-author cite{font:400 22px/1.0em Roboto Slab;color:#000000}
	.h4, h4,li.product h3,.woocommerce .upsells.products h2,.woocommerce .related.products h2,.woocommerce ul.cart_list li a,.woocommerce ul.product_list_widget li a,.woocommerce-page ul.cart_list li a,.woocommerce-page ul.product_list_widget li a {font:700 16px/1.5em Roboto Slab;color:#000000}
	.h5, h5,p.meta,.meta a{font:300 14px/1.5em Roboto Slab;color:#807d80}
	h6 {font:300 14px/1.5em Roboto Slab;color:#807d80}

	#main-nav>li>a,.searchform input.s,.woocommerce a.button{font:300 18px/1.0em Open Sans;color:#000}
	ul.social-menu li a{font:300 18px/1.0em }.tab-post small a,.taggs a {color:#545454}
</style>
<style>.mc4wp-checkbox-wp-registration-form{clear:both;display:block;position:static;width:auto}.mc4wp-checkbox-wp-registration-form input{float:none;width:auto;position:static;margin:0 6px 0 0;padding:0;vertical-align:middle;display:inline-block!important;max-width:21px;-webkit-appearance:checkbox}.mc4wp-checkbox-wp-registration-form label{float:none;display:block;cursor:pointer;width:auto;position:static;margin:0 0 16px 0}</style><style id="custom-background-css">
body.custom-background { background-color: #fcfcfc; }
</style>
<meta property="og:site_name" content="Euromaidan Press" />
<meta property="og:type" content="article" />
<meta property="og:locale" content="en_US" />
<meta property="fb:app_id" content="1395391370748120" />
<meta property="og:url" content="https://euromaidanpress.com/2022/03/04/international-cyberoffensive-gives-russia-a-sip-of-its-own-bitter-medicine/" />
<meta property="og:title" content="International cyberoffensive gives Russia “a sip of its own bitter medicine”" />
<meta property="og:description" content="On 1 March 2022, the Minister of Digital Transformation of Ukraine Mychaylo Fedorov, who previously launched the IT Army of Ukraine, wrote: “If in the beginning we constrained many powerful cyberattacks, mainly due to the long preparation of Russia in advance, now, thanks to the common spirit of Ukrainians for freedom, we have moved to…" />
<meta property="og:image" content="https://euromaidanpress.com/wp-content/uploads/2022/03/word-image-18.png" />
<meta property="og:image:width" content="977" />
<meta property="og:image:height" content="650" />
<meta property="og:image" content="https://euromaidanpress.com/wp-content/uploads/2022/03/a-picture-containing-logo-description-automatical.png" />
<meta property="og:image:width" content="680" />
<meta property="og:image:height" content="379" />
<meta property="og:image" content="https://euromaidanpress.com/wp-content/uploads/2022/03/word-image-13.png" />
<meta property="og:image:width" content="977" />
<meta property="og:image:height" content="731" />
<meta property="article:published_time" content="2022-03-04T12:51:26+00:00" />
<meta property="article:modified_time" content="2022-03-04T13:20:28+00:00" />
<meta property="article:author" content="https://euromaidanpress.com/author/orysia/" />
<meta property="article:section" content="International" />
<meta property="article:tag" content="Russian Aggression" />
<meta property="article:tag" content="cyber attacks" />
<meta property="article:tag" content="cybersecurity" />
<meta property="article:tag" content="cyberwar" />
<style>
		/*<!-- rtoc -->*/
		.rtoc-mokuji-content {
			background-color: #ffffff;
		}

		.rtoc-mokuji-content.frame1 {
			border: 1px solid #555555;
		}

		.rtoc-mokuji-content #rtoc-mokuji-title {
			color: #333333;
		}

		.rtoc-mokuji-content .rtoc-mokuji li>a {
			color: #333333;
		}

		.rtoc-mokuji-content .mokuji_ul.level-1>.rtoc-item::before {
			background-color: #333333 !important;
		}

		.rtoc-mokuji-content .mokuji_ul.level-2>.rtoc-item::before {
			background-color: #bfbfbf !important;
		}
		.rtoc-mokuji-content.frame2::before, .rtoc-mokuji-content.frame3, .rtoc-mokuji-content.frame4, .rtoc-mokuji-content.frame5{
			border-color:#555555;
		}
		.rtoc-mokuji-content.frame5::before, .rtoc-mokuji-content.frame5::after{
			background-color:#555555;
		}

		.cls-1,
		.cls-2 {
			stroke: #555555;
		}

		.rtoc-mokuji-content .decimal_ol.level-2>.rtoc-item::before,
		.rtoc-mokuji-content .mokuji_ol.level-2>.rtoc-item::before,
		.rtoc-mokuji-content .decimal_ol.level-2 > .rtoc-item::after {
			color: #bfbfbf;
			background-color: #bfbfbf;
		}
		.rtoc-mokuji-content .rtoc-mokuji.level-1 > .rtoc-item::before{
			color: #333333;
		}

		.rtoc-mokuji-content .decimal_ol>.rtoc-item::after {
			background-color: #333333;
		}

		.rtoc-mokuji-content .decimal_ol>.rtoc-item::before {
			color: #333333;
		}
		/*rtoc_return*/
		#rtoc_return a::before {
			background-image: url(https://static2.euromaidanpress.com/wp-content/plugins/rich-table-of-content/include/../img/rtoc_return.png);
		}

		#rtoc_return a {
			background-color: #333333 !important;
		}

		/* アクセントポイント */
		.rtoc-mokuji-content .level-1>.rtoc-item #rtocAC.accent-point::after {
			background-color: #333333;
		}

		.rtoc-mokuji-content .level-2>.rtoc-item #rtocAC.accent-point::after {
			background-color: #bfbfbf;
		}
		/* rtoc_addon */
		
	</style>

<script>

jQuery(document).ready(function($) {

if(typeof $ !== 'undefined')jQuery=$.noConflict();
else if(typeof jQuery !== 'undefined') $=jQuery.noConflict();

});

jQuery(document).ready(function($) {

  
  // responsive youtube videos - stretch proportionally to 100% width of video's parent element

  jQuery("#core iframe[src^='https://www.youtube.com/embed']").each(function(index){
      //console.log(index + ': ' + jQuery(this).attr('src'))
      var w = jQuery(this).attr('width'), 
          h = jQuery(this).attr('height'),
          p= jQuery(this).parent().innerWidth()
      if(w && h && p){
         // console.log(w+'x'+h+ ', new='+p+'x' + p*h/w)
          jQuery(this).attr('width', p);
          jQuery(this).attr('height', p*h/w);
          }
      });
  
  
  //make tables responsive
  
  //var is_mobile = jQuery(window).width() < 640 ? true : false;
  //jQuery( is_mobile? 'table' : 'table.scroll' ).wrap( "<div class='table_wrapper'></div>" );
  jQuery( 'table.scrollable').wrap( "<div class='table_wrapper'></div>" );
  jQuery( 'table.covid_table').wrap("<div class='table_wrapper'></div>");
  //Scrolling down the target of #-links to not be overlapped by the fixed top-menu:
  var offset = jQuery(':target').offset();
  if(offset){
    var scrollto = offset.top - 60 - 30; // minus fixed header height minus some 30 more px
    jQuery('html, body').animate({scrollTop:scrollto}, 0);
    }

    jQuery(window).scroll( function(){
        jQuery(".fl_animation").each( function(i){
            var bottom_of_element = jQuery(this).offset().top + jQuery(this).outerHeight();
            var bottom_of_window = jQuery(window).scrollTop() + jQuery(window).height();
            if( bottom_of_window > bottom_of_element ){
                jQuery(this).animate({"opacity":"1"},500);
            }
        }); 
    });
//   jQuery(".tooltips").append("<span class='nostyle'>" + (/fa-info-circle/.test(jQuery(this).html()) ? "<i class='omsc-icon fa fa-info-circle'></i>": "" ) + "</span>")
//jQuery(".tooltips").append(function(){return /fa-info-circle/.test(jQuery(this).html()) ? "" : "<span class='nostyle'> <i class='omsc-icon fa fa-info-circle'></i></span>"  })
jQuery(".tooltips").each(function(){if(-1 == this.innerHTML.indexOf('info-circle')) jQuery(this).append("<span class='nostyle'> <i class='omsc-icon fa fa-info-circle'></i></span>")  })



});
</script>

<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-N95BHB7');</script>


<meta name="cf-2fa-verify" content="cf_564364643465415646411" />
<script type="text/javascript">var ezouid = "1";</script><base href="https://euromaidanpress.com/2022/03/04/international-cyberoffensive-gives-russia-a-sip-of-its-own-bitter-medicine/"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script>

<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 6354;
var ezdomain = 'euromaidanpress.com';
var ezoicSearchable = 0;
</script>


<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ab_test_id":"mod40","ad_cache_level":0,"ad_lazyload_version":0,"ad_load_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":6354,"engaged_time_visit":0,"ezcache_level":0,"ezcache_skip_code":0,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"0669fce4-55d2-4db6-40e2-ccbf6c7a01ed","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_size_orig":203644,"response_time_orig":0,"serverid":"3.68.78.169:19572","state":"VA","t_epoch":1646406939,"template_id":126,"time_on_site_visit":0,"url":"https://euromaidanpress.com/2022/03/04/international-cyberoffensive-gives-russia-a-sip-of-its-own-bitter-medicine/","user_id":0,"visit_uuid":"894b8e98-bed5-4f90-432d-62a64b5a8928","word_count":2556,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script><script data-ezscrex='false' data-cfasync='false' type="text/javascript">var ezWp = true;</script>
<script src="//www.ezojs.com/ezoic/ezd.js" defer async></script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_6354=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["0669fce4-55d2-4db6-40e2-ccbf6c7a01ed", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script><script async src='/cdn-cgi/challenge-platform/h/g/scripts/invisible.js'></script></head>
<body class="post-template-default single single-post postid-160604 single-format-standard custom-background upper html5_presentation _masterslider _ms_version_3.8.1" itemscope="" itemtype="http://schema.org/WebPage">

<script async="" src="https://www.googletagmanager.com/gtag/js?id=UA-30994008-3"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());
  gtag('config', 'UA-30994008-3');
</script>


<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-N95BHB7"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

<div id="header" class="" itemscope="" itemtype="http://schema.org/WPHeader">

<div class="container">
<div class="clearfix"></div>
<div style="float:right">
<form class="searchform" method="get" action="https://euromaidanpress.com">
<input type="text" name="s" class="s" size="30" value="Search" onfocus="if (this.value = &#39;&#39;) {this.value = &#39;&#39;;}" onblur="if (this.value == &#39;&#39;) {this.value = &#39;Search...&#39;;}" /><button class="searchSubmit"><i class="fa fa-search"></i></button>
</form><ul class="social-menu">
<li class="sprite-facebook"><a target="_blank" class="mk-social-facebook" title="Facebook" href="https://www.facebook.com/euromaidanpress.en"></a></li>
<li class="sprite-twitter"><a target="_blank" class="mk-social-twitter-alt" title="Twitter" href="https://twitter.com/EuromaidanPress"></a></li>
<li class="socialtrigger">
<a title="Show More" href="#">+</a>
<ul class="social-menu-more">
<li class="sprite-pinterest"><a target="_blank" class="mk-social-pinterest" title="Pinterest" href="https://www.pinterest.com/euromaidanpress/"></a></li>
<li class="sprite-youtube"><a target="_blank" class="mk-social-youtube" title="You Tube" href="https://www.youtube.com/channel/UC2HnikxQ0KklXJwmN0VSkVg"></a></li>
</ul>
</li>
</ul>
</div>
<div class="h1">
<a class="logo" href="https://euromaidanpress.com/">
<img id="logo" src="/wp-content/uploads/2015/05/empressologo8003.jpg" alt="Euromaidan Press" />
</a>
</div>
<div class="clearfix"></div>
<div id="navigation_wrap">
<a id="triggernav" href="#">MENU</a>
<nav id="navigation" itemscope="" itemtype="http://schema.org/SiteNavigationElement">
<ul id="main-nav" class="nav custom-nav"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-122632"><a href="https://euromaidanpress.com/category/ukraine/">Ukraine</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122637"><a href="https://euromaidanpress.com/category/ukraine/reforms-politics/political-news/">Politics</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122638"><a href="https://euromaidanpress.com/category/ukraine/reforms-politics/reforms/">Reforms</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122640"><a href="https://euromaidanpress.com/category/ukraine/history/">History</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122635"><a href="https://euromaidanpress.com/category/ukraine/culture/">Culture</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122639"><a href="https://euromaidanpress.com/category/ukraine/civil-society/">Civil Society</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122862"><a href="https://euromaidanpress.com/category/russian-aggression/political-prisoners/">Political prisoners</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122636"><a href="https://euromaidanpress.com/category/ukraine/people-of-ukraine/">People of Ukraine</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-122630"><a href="https://euromaidanpress.com/category/international/">International</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-122631"><a href="https://euromaidanpress.com/category/russian-aggression/">Russian Aggression</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122643"><a href="https://euromaidanpress.com/category/russian-aggression/hybrid-war/">Hybrid War</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122641"><a href="https://euromaidanpress.com/category/russian-aggression/donetsk-luhansk/">Donbas</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122642"><a href="https://euromaidanpress.com/category/russian-aggression/crimea/">Crimea</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122644"><a href="https://euromaidanpress.com/category/russian-aggression/peace-to-ukraine/">Peace to Ukraine</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-122633"><a href="https://euromaidanpress.com/category/more/">More</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-147354"><a href="https://euromaidanpress.com/category/more/opinion/">Opinion</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-122650"><a href="https://euromaidanpress.com/category/more/special-projects/">Special projects</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-147351"><a href="https://euromaidanpress.com/category/more/special-projects/plus1/">Plus1</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122646"><a href="https://euromaidanpress.com/category/more/faqs/">FAQs</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-122634"><a href="https://euromaidanpress.com/about/">About Us</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154319"><a href="https://euromaidanpress.com/about/">About Us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-122648"><a href="https://euromaidanpress.com/about/partners/">Patrons, donors, and partners</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-122649"><a href="https://euromaidanpress.com/contribute/">Contribute</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-146072"><a href="https://euromaidanpress.com/donate/">Support us</a></li>
</ul>
</li>
</ul>
</nav>
</div>
</div>
</div>
<div class="clearfix"></div>
<div class="container  upper" itemscope="" itemprop="mainContentOfPage" itemtype="http://schema.org/WebPageElement">


<p id="breadcrumbs"><span><span><a href="https://euromaidanpress.com/">Home</a> » <span><a href="https://euromaidanpress.com/category/russian-aggression/">Russian Aggression</a> » <span class="breadcrumb_last" aria-current="page">International cyberoffensive gives Russia “a sip of its own bitter medicine”</span></span></span></span></p>
<div id="core" class="Right">
<div class="post-160604 post type-post status-publish format-standard has-post-thumbnail hentry category-international category-russian-aggression tag-cyber-attacks tag-cybersecurity tag-cyberwar" data-story-id="160604" data-theme="view" data-type="article" itemscope="" itemtype="http://schema.org/Article">
<link itemprop="mainEntityOfPage" href="https://euromaidanpress.com/2022/03/04/international-cyberoffensive-gives-russia-a-sip-of-its-own-bitter-medicine/" />

<article>
<h1 class="post entry-title" itemprop="headline"><a href="https://euromaidanpress.com/2022/03/04/international-cyberoffensive-gives-russia-a-sip-of-its-own-bitter-medicine/">International cyberoffensive gives Russia “a sip of its own bitter medicine”</a></h1>
<div class="clearfix"></div>
<div id="content" class="eightcol">
<div class="entry" itemprop="text">

<span itemprop="image" itemscope="" itemtype="http://schema.org/ImageObject">
<meta itemprop="url" content="https://static.euromaidanpress.com/wp-content/uploads/2022/03/word-image-18.png" />
<meta itemprop="width" content="128" />
<meta itemprop="height" content="85" />
<img width="977" height="650" src="https://static.euromaidanpress.com/wp-content/uploads/2022/03/word-image-18.png" class="attachment-format-standard size-format-standard wp-post-image" alt="International cyberoffensive gives Russia “a sip of its own bitter medicine”" srcset="https://static.euromaidanpress.com/wp-content/uploads/2022/03/word-image-18.png 977w, https://static.euromaidanpress.com/wp-content/uploads/2022/03/word-image-18-300x200.png 300w" sizes="(max-width: 977px) 100vw, 977px" data-attachment-id="160614" data-permalink="https://euromaidanpress.com/2022/03/04/international-cyberoffensive-gives-russia-a-sip-of-its-own-bitter-medicine/word-image-2938/" data-orig-file="https://static.euromaidanpress.com/wp-content/uploads/2022/03/word-image-18.png" data-orig-size="977,650" data-comments-opened="0" data-image-meta="{&#34;aperture&#34;:&#34;0&#34;,&#34;credit&#34;:&#34;&#34;,&#34;camera&#34;:&#34;&#34;,&#34;caption&#34;:&#34;&#34;,&#34;created_timestamp&#34;:&#34;0&#34;,&#34;copyright&#34;:&#34;&#34;,&#34;focal_length&#34;:&#34;0&#34;,&#34;iso&#34;:&#34;0&#34;,&#34;shutter_speed&#34;:&#34;0&#34;,&#34;title&#34;:&#34;&#34;,&#34;orientation&#34;:&#34;0&#34;}" data-image-title="word-image" data-image-description="" data-image-caption="&lt;p&gt;Illustrative photo&lt;/p&gt;
" data-medium-file="https://static.euromaidanpress.com/wp-content/uploads/2022/03/word-image-18-300x200.png" data-large-file="https://static.euromaidanpress.com/wp-content/uploads/2022/03/word-image-18.png" /><p><i class="post-thumbnail-caption">Illustrative photo </i></p>
</span>
<div class="clearfix"></div>
<p class="meta">

<time class="article-timestamp" itemprop="datePublished" datetime="2022-03-04T14:51:26.000+02:00" data-type="updated">
2022/03/04 - 14:51 •
</time>
<time class="article-timestamp" itemprop="dateModified" datetime="2022-03-04T15:20:28.000+02:00" data-type="updated">
</time>
<a href="https://euromaidanpress.com/category/international/" rel="category tag">International</a>, <a href="https://euromaidanpress.com/category/russian-aggression/" rel="category tag">Russian Aggression</a>
</p>
<span itemprop="publisher" itemscope="" itemtype="https://schema.org/Organization">
<meta itemprop="name" content="Euromaidan Press" />
<span itemprop="logo" itemscope="" itemtype="https://schema.org/ImageObject">
<meta itemprop="url" content="https://euromaidanpress.com/wp-content/uploads/2017/07/logo_gn.png" />
<meta itemprop="width" content="467" />
<meta itemprop="height" content="91" />
</span>
</span>
<div class="code-block code-block-3" style="margin: 8px auto; text-align: center; display: block; clear: both;">
<div id="top-banner" style="overflow: visible">

</div>
</div>
<div class="fb-social-plugin fb-like" data-ref="above-post" data-href="https://euromaidanpress.com/2022/03/04/international-cyberoffensive-gives-russia-a-sip-of-its-own-bitter-medicine/" data-layout="button_count" data-share="true" data-width="960"></div>
<div class="h4 meta author">
<div class="meta author">Article by: <b>Orysia Hrudka</b></div>
<div class="meta editor">Edited by: Sonia Maryn</div>
</div>
<div class="omsc-infobox" style="background: #ededb1; border-color: #ededb1; color: #000000;"><p style="padding-top: 1em;"><span style="display: block; background-color: #05acfa !important; padding: 5px; position: absolute; top: 0; right: 0; color: white; font-family: &#39;Open Sans&#39;;">Editor’s Note</span></p><div id="ezoic-pub-ad-placeholder-104" data-inserter-version="2"></div>An international cyber offensive on Russia is gaining steam as the collective Anonymous takes down Russian and Belarusian state websites and services. As well, the Ukrainian government has launched an “IT Army of Ukraine” in what is the first time that a state has openly called for citizens and volunteers to cyberattack another state.<p></p>
<p>At the same time, Russia’s cyberattacks on Ukraine after the full-scale invasion are surprisingly meager.</p><div id="ezoic-pub-ad-placeholder-112" data-inserter-version="2"></div></div>
<p>On 1 March 2022, the Minister of Digital Transformation of Ukraine Mychaylo Fedorov, who previously launched the IT Army of Ukraine, <a href="https://www.facebook.com/mykhailofedorov.com.ua/posts/1007320006552185">wrote</a>:</p>
<blockquote><p>“<em>If in the beginning we constrained many powerful cyberattacks, mainly due to the long preparation of Russia in advance, now, thanks to the common spirit of Ukrainians for freedom, we have moved to a confident offensive.</em>”</p></blockquote>
<p>Soon after the first cyberattacks on Russia by Anonymous, an international hacker activist group – the IT army of Ukraine — was launched. While there have been a number of successful cyber attacks on Russia, Russia is much less active in cyber attacks than was expected. There are a number of possible reasons.</p>
<h3 id="rtoc-1">Anonymous declares cyberwar against the Russian government on the very day of the invasion</h3>
<p>On 24 February, the day <a href="https://euromaidanpress.com/2022/03/01/why-russia-attacked-ukraine/?swcfpc=1">Russia invaded Ukraine</a>, Anonymous, one of the largest and most widely-known hacker groups, <a href="https://twitter.com/YourAnonOne/status/1496965766435926039">declared</a> it is “officially in cyberwar against the Russian government.”</p><div id="ezoic-pub-ad-placeholder-113" data-inserter-version="2"></div>
<p>The damage did not take long to be felt. The very next day, 25 February, Anonymous <a href="https://twitter.com/YourAnonTV/status/1497326134802984960?ref_src=twsrc%5Etfw%7Ctwcamp%5Etweetembed%7Ctwterm%5E1497326134802984960%7Ctwgr%5E%7Ctwcon%5Es1_&amp;ref_url=https%3A%2F%2Fmetro.co.uk%2F2022%2F02%2F26%2Fanonymous-leaks-russian-mod-database-in-major-victory-during-cyberwar-16179039%2F">breached</a> the Russian Ministry of Defence’s database and posted it online for Ukraine and the world to see.</p>
<div class="epyt-video-wrapper"><iframe loading="lazy" style="display: block; margin: 0px auto;" id="_ytid_32392" width="960" height="540" data-origwidth="960" data-origheight="540" data-relstop="1" src="https://www.youtube.com/embed/31OIdBg91WI?enablejsapi=1&amp;origin=https://euromaidanpress.com&amp;autoplay=0&amp;cc_load_policy=1&amp;cc_lang_pref=&amp;iv_load_policy=3&amp;loop=0&amp;modestbranding=1&amp;rel=0&amp;fs=1&amp;playsinline=0&amp;autohide=1&amp;theme=light&amp;color=red&amp;controls=1&amp;" class="__youtube_prefs__  epyt-is-override  no-lazyload" title="YouTube player" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen="" data-no-lazy="1" data-skipgform_ajax_framebjll=""></iframe></div>
<h5 style="text-align: right;"><em>The Anonymous mask, known from the novel and movies V (Vendetta), was first donned by England’s famous rebel<a href="https://metro.co.uk/2021/11/05/bonfire-night-11-surprising-facts-about-guy-fawkes-and-the-gunpowder-plot-15547817/"> Guy Fawkes, a conspirator in the 1605 Gunpowder Plot</a>.</em></h5>
<p>According to Anonymous, on 25 February they <strong><a href="https://twitter.com/YourAnonTV/status/1498356267416489986">took down</a> 1,500 websites of the Russian and Belarusian governments,</strong> <a href="https://twitter.com/YourAnonCentral/status/1497744022659493891?ref_src=twsrc%5Etfw%7Ctwcamp%5Etweetembed%7Ctwterm%5E1497744022659493891%7Ctwgr%5E%7Ctwcon%5Es1_&amp;ref_url=https%3A%2F%2Fd-21773457241082009077.ampproject.net%2F2202230359001%2Fframe.html">including</a> the website of the Ministry of Defense, the Kremlin, and the Federal Anti-Monopoly Service.</p>
<p>On 2 March, the group reported that one of their affiliated hacking splinter groups <strong><a href="https://twitter.com/YourAnonTV/status/1498792639877074945">had shut down</a> the Russian space agency Roscosmos</strong> which is responsible for Russia’s control over Russian spy satellites. It also<strong> <a href="https://twitter.com/YourAnonOne/status/1497631016667787270">intercepted</a> several streams of Russian military communication.</strong></p>
<p><strong>Russian TV channels</strong> <a href="https://twitter.com/Beczkax1/status/1497571513482063874?ref_src=twsrc%5Etfw%7Ctwcamp%5Etweetembed%7Ctwterm%5E1497571513482063874%7Ctwgr%5E%7Ctwcon%5Es1_&amp;ref_url=https%3A%2F%2Ftheconversation.com%2Fthe-hacker-group-anonymous-has-waged-a-cyber-war-against-russia-how-effective-could-they-actually-be-178034">were also attacked</a>, playing Ukrainian music and displaying national symbols. The attack brought uncensored news of the conflict from news sources outside Russia. <strong>Russia Today,</strong> the state-backed news service, was also <a href="https://twitter.com/YourAnonCentral/status/1497744022659493891?ref_src=twsrc%5Etfw%7Ctwcamp%5Etweetembed%7Ctwterm%5E1497744022659493891%7Ctwgr%5E%7Ctwcon%5Es1_&amp;ref_url=https%3A%2F%2Fd-21773457241082009077.ampproject.net%2F2202230359001%2Fframe.html">taken down</a> with DDoS (Distributed Denial of Service) attacks. This type of attack works by overwhelming a target website with fake traffic.</p><div id="ezoic-pub-ad-placeholder-114" data-inserter-version="2"></div>
<p>On 28 February, Russian media sites, including <strong>TASS</strong> and <strong>Kommersant,</strong> were blanked out to display “5,300,” the number of Russian troops killed by Ukraine’s army according to official data.</p>
<p>That same day, Anonymous <a href="https://twitter.com/YourAnonNews/status/1498357935260454917?ref_src=twsrc%5Etfw%7Ctwcamp%5Etweetembed%7Ctwterm%5E1498357935260454917%7Ctwgr%5E%7Ctwcon%5Es1_&amp;ref_url=https%3A%2F%2Fd-2082249863584549771.ampproject.net%2F2202230359001%2Fframe.html">addressed</a> Russians in an ominous tweet.</p>
<blockquote><p><em>“Understand that Putin has invaded a sovereign nation and the whole world is outraged. We know it’s risky to stand up to him, but if you don’t, then who will?”</em></p></blockquote>
<div id="attachment_160609" style="width: 690px" class="wp-caption alignnone"><img data-attachment-id="160609" data-permalink="https://euromaidanpress.com/2022/03/04/international-cyberoffensive-gives-russia-a-sip-of-its-own-bitter-medicine/a-picture-containing-logo-description-automatical-2/" data-orig-file="https://static.euromaidanpress.com/wp-content/uploads/2022/03/a-picture-containing-logo-description-automatical-1.png" data-orig-size="680,379" data-comments-opened="0" data-image-meta="{&#34;aperture&#34;:&#34;0&#34;,&#34;credit&#34;:&#34;&#34;,&#34;camera&#34;:&#34;&#34;,&#34;caption&#34;:&#34;&#34;,&#34;created_timestamp&#34;:&#34;0&#34;,&#34;copyright&#34;:&#34;&#34;,&#34;focal_length&#34;:&#34;0&#34;,&#34;iso&#34;:&#34;0&#34;,&#34;shutter_speed&#34;:&#34;0&#34;,&#34;title&#34;:&#34;&#34;,&#34;orientation&#34;:&#34;0&#34;}" data-image-title="a-picture-containing-logo-description-automatical" data-image-description="" data-image-caption="" data-medium-file="https://static.euromaidanpress.com/wp-content/uploads/2022/03/a-picture-containing-logo-description-automatical-1-300x167.png" data-large-file="https://static.euromaidanpress.com/wp-content/uploads/2022/03/a-picture-containing-logo-description-automatical-1.png" aria-describedby="caption-attachment-160609" loading="lazy" class="wp-image-160609" src="https://static.euromaidanpress.com/wp-content/uploads/2022/03/a-picture-containing-logo-description-automatical-1.png" alt="A picture containing logoDescription automatically generated" width="680" height="379" srcset="https://static.euromaidanpress.com/wp-content/uploads/2022/03/a-picture-containing-logo-description-automatical-1.png 680w, https://static.euromaidanpress.com/wp-content/uploads/2022/03/a-picture-containing-logo-description-automatical-1-300x167.png 300w" sizes="(max-width: 680px) 100vw, 680px" /><p id="caption-attachment-160609" class="wp-caption-text">Picture from Anonymous <a href="https://twitter.com/YourAnonNews/status/1498357935260454917?ref_src=twsrc%5Etfw%7Ctwcamp%5Etweetembed%7Ctwterm%5E1498357935260454917%7Ctwgr%5E%7Ctwcon%5Es1_&amp;ref_url=https%3A%2F%2Fd-2082249863584549771.ampproject.net%2F2202230359001%2Fframe.html">tweet</a></p><div id="ezoic-pub-ad-placeholder-115" data-inserter-version="2"></div></div>
<blockquote><p><em>​​“DDoS alone will not bring down a regime,” </em>a German Anonymous splinter group <a href="https://www.independent.co.uk/tech/anonymous-russia-hackers-ukraine-message-b2024989.html?page=2">posted</a> in a blog. <em>“[But Putin] who is using hacker squads and troll armies against Western democracies, is getting a sip of his own bitter medicine. [The intention is to] keep the Russian IT apparatus busy and to provide Putin’s hacker troops … with defensive work so that they cannot do anything in Ukraine or the West. Obtaining information is also an important point and you just don’t see a lot of what activists are currently doing.</em>”</p></blockquote>
<p>It is also important to note that Anonymous activity is highly decentralized, so it is difficult to definitively attribute all these attacks to Anonymous. However, as Jamie Collier, a consultant at U.S. cybersecurity firm Mandiant, <a href="https://www.theguardian.com/world/2022/feb/27/anonymous-the-hacker-collective-that-has-declared-cyberwar-on-russia">explained</a> about recent Anonymous activity:</p>
<blockquote><p><em>“It can be difficult to directly tie this activity to Anonymous, as targeted entities will likely be reluctant to publish related technical data. However, the Anonymous collective has a track record of conducting this sort of activity and it is very much in line with their capabilities.”</em></p></blockquote>
<div id="attachment_160611" style="width: 987px" class="wp-caption alignnone"><img data-attachment-id="160611" data-permalink="https://euromaidanpress.com/2022/03/04/international-cyberoffensive-gives-russia-a-sip-of-its-own-bitter-medicine/word-image-2935/" data-orig-file="https://static.euromaidanpress.com/wp-content/uploads/2022/03/word-image-16.png" data-orig-size="977,731" data-comments-opened="0" data-image-meta="{&#34;aperture&#34;:&#34;0&#34;,&#34;credit&#34;:&#34;&#34;,&#34;camera&#34;:&#34;&#34;,&#34;caption&#34;:&#34;&#34;,&#34;created_timestamp&#34;:&#34;0&#34;,&#34;copyright&#34;:&#34;&#34;,&#34;focal_length&#34;:&#34;0&#34;,&#34;iso&#34;:&#34;0&#34;,&#34;shutter_speed&#34;:&#34;0&#34;,&#34;title&#34;:&#34;&#34;,&#34;orientation&#34;:&#34;0&#34;}" data-image-title="word-image" data-image-description="" data-image-caption="" data-medium-file="https://static.euromaidanpress.com/wp-content/uploads/2022/03/word-image-16-300x224.png" data-large-file="https://static.euromaidanpress.com/wp-content/uploads/2022/03/word-image-16.png" aria-describedby="caption-attachment-160611" loading="lazy" class="wp-image-160611" src="https://static.euromaidanpress.com/wp-content/uploads/2022/03/word-image-16.png" alt="Photo: Railway station Rudziensk, Belarus. Wikimedia Commons ~" width="977" height="731" srcset="https://static.euromaidanpress.com/wp-content/uploads/2022/03/word-image-16.png 977w, https://static.euromaidanpress.com/wp-content/uploads/2022/03/word-image-16-300x224.png 300w" sizes="(max-width: 977px) 100vw, 977px" /><p id="caption-attachment-160611" class="wp-caption-text">Photo: Railway station Rudziensk, Belarus. Wikimedia Commons</p><div id="ezoic-pub-ad-placeholder-116" data-inserter-version="2"></div></div>
<p>There are examples of other hacker groups launching cyber attacks. One is the Belarus group, Cyber Partisans. When the self-proclaimed president of Belarus, Alexander Lukashenka joined Russia’s invasion, the Cyber Partisans <a href="https://twitter.com/cpartisans/status/1497930273425661958">attacked</a> the Belarus Railway Service website to slow down the movement of the country’s troops. As of 2 March, the Cyber Partisans report that the <a href="https://twitter.com/cpartisans/status/1499028956305149954?ref_src=twsrc%5Egoogle%7Ctwcamp%5Eserp%7Ctwgr%5Etweet">attack</a> on the railway continues.</p>
<h3 id="rtoc-2">26 February: Ukraine launches IT army</h3>
<p>On 26 February, the Minister of Digital Transformations of Ukraine Mychaylo Fedorov <a href="https://twitter.com/fedorovmykhailo/status/1497642156076511233?s=21">announced</a> on Twitter:</p>
<blockquote><p><em>“We are creating an IT army. We need digital talents. All operational tasks will be given here:<a href="https://t.co/Ie4ESfxoSn"> https://t.me/itarmyofurraine</a>. There will be tasks for everyone. We continue to fight on the cyber front. The first task is on the channel for cyber specialists.”</em></p></blockquote>
<p>Fedorov then posted on Facebook:</p><div id="ezoic-pub-ad-placeholder-117" data-inserter-version="2"></div>
<blockquote><p><em>“We have a lot of talented Ukrainians in the digital sphere: developers, cyber specialists, designers, copywriters, marketers …”</em></p></blockquote>
<p>Hundreds of people started joining the IT army immediately after this announcement – as of 2 March, there are more than <a href="https://web.telegram.org/z/#-1601423054">​​270,000</a> subscribers in the IT army chat. These subscribers are not only IT specialists but include people who are helping to inform the citizens of Russia and Belarus about the true situation in Ukraine. All media in Russia and Belarus is heavily controlled – essentially propaganda.</p>
<div class="tmnf-sc-box normal   ">“<em>It is the first time that states have openly called for citizens and volunteers to cyberattack another state,</em>” <a href="https://www.independent.co.uk/tech/russia-cyber-attack-ukraine-anonymous-b2025500.html">said</a> Gabriella Coleman, a Harvard anthropology professor who has charted the rise of hacktivism.</div>
<p>The IT army <a href="https://www.facebook.com/mykhailofedorov.com.ua/posts/1006525126631673">took down</a> a technology used by one of Russia’s biggest banks, <strong>Sberbank.</strong> The main Russian money master – the <strong>Moscow Exchange</strong> – <a href="https://www.facebook.com/mykhailofedorov.com.ua/posts/1006477873303065">came down</a> at the start of the workweek, 28 February.</p>
<div id="attachment_160612" style="width: 1930px" class="wp-caption alignnone"><img data-attachment-id="160612" data-permalink="https://euromaidanpress.com/2022/03/04/international-cyberoffensive-gives-russia-a-sip-of-its-own-bitter-medicine/word-image-2936/" data-orig-file="https://static.euromaidanpress.com/wp-content/uploads/2022/03/word-image-6-e1646396480400.jpeg" data-orig-size="700,467" data-comments-opened="0" data-image-meta="{&#34;aperture&#34;:&#34;0&#34;,&#34;credit&#34;:&#34;&#34;,&#34;camera&#34;:&#34;&#34;,&#34;caption&#34;:&#34;&#34;,&#34;created_timestamp&#34;:&#34;0&#34;,&#34;copyright&#34;:&#34;&#34;,&#34;focal_length&#34;:&#34;0&#34;,&#34;iso&#34;:&#34;0&#34;,&#34;shutter_speed&#34;:&#34;0&#34;,&#34;title&#34;:&#34;&#34;,&#34;orientation&#34;:&#34;0&#34;}" data-image-title="word-image" data-image-description="" data-image-caption="" data-medium-file="https://static.euromaidanpress.com/wp-content/uploads/2022/03/word-image-6-300x200.jpeg" data-large-file="https://static.euromaidanpress.com/wp-content/uploads/2022/03/word-image-6-1024x683.jpeg" aria-describedby="caption-attachment-160612" loading="lazy" class="wp-image-160612" src="https://static.euromaidanpress.com/wp-content/uploads/2022/03/word-image-6.jpeg" alt="Photo: Sberbank, Russian majority state-owned bank. Creative Commons ~" width="1920" height="1280" /><p id="caption-attachment-160612" class="wp-caption-text">Photo: Sberbank, Russian majority state-owned bank. Creative Commons</p><div id="ezoic-pub-ad-placeholder-118" data-inserter-version="2"></div></div>
<p>There have been attacks on Russian official websites, as well as the web resources of Belarus. The website of <strong>Russia’s Investigative Committee,</strong> the<strong> FSB, Sberbank</strong>, and other government and critical information systems both for Russia and Belarus <a href="https://www.facebook.com/100069027285973/posts/266463788997862/">have been</a> taken down.</p>
<p>Among the known blocked resources are</p>
<ul>
<li>sberbank.ru</li>
<li>vsrf.ru</li>
<li>scrf.gov.ru</li>
<li>kremlin.ru</li>
<li>radiobelarus.by</li>
<li>rec.gov.by</li>
<li>sb.by</li>
<li>belarus.by</li>
<li>belta.by</li>
<li>tvr.by</li>
</ul>
<blockquote><p>“<em>For a country that’s facing an existential threat like Ukraine, it’s really not surprising that this sort of call would go out and that some citizens would respond … Part of it is also a signaling exercise. It’s signaling a level of commitment across the country of Ukraine to resisting what the Russians are doing,</em>”<a href="https://www.wired.co.uk/article/ukraine-it-army-russia-war-cyberattacks-ddos"> said</a> J. <strong>Michael Daniel,</strong> head of the industry group Cyber Threat Alliance and former White House cyber coordinator for President Barack Obama</p></blockquote>
<p>On 24 February, an attack was made on information resources and the main contractor of all state projects in information technology in Russia, Systematics. The owner of Systematics is Putin’s “right-hand” Dmitry Medvedev. The evolution of Systematics included the automated electoral system Elections that were used to legitimize Putin’s regime for years. It too was disabled.</p><div id="ezoic-pub-ad-placeholder-119" data-inserter-version="2"></div>
<blockquote><p>“<em>So Russians will now vote the old way, on paper,</em>” Nikonov suggested.</p></blockquote>
<div id="attachment_160613" style="width: 987px" class="wp-caption alignnone"><img data-attachment-id="160613" data-permalink="https://euromaidanpress.com/2022/03/04/international-cyberoffensive-gives-russia-a-sip-of-its-own-bitter-medicine/word-image-2937/" data-orig-file="https://static.euromaidanpress.com/wp-content/uploads/2022/03/word-image-17.png" data-orig-size="977,643" data-comments-opened="0" data-image-meta="{&#34;aperture&#34;:&#34;0&#34;,&#34;credit&#34;:&#34;&#34;,&#34;camera&#34;:&#34;&#34;,&#34;caption&#34;:&#34;&#34;,&#34;created_timestamp&#34;:&#34;0&#34;,&#34;copyright&#34;:&#34;&#34;,&#34;focal_length&#34;:&#34;0&#34;,&#34;iso&#34;:&#34;0&#34;,&#34;shutter_speed&#34;:&#34;0&#34;,&#34;title&#34;:&#34;&#34;,&#34;orientation&#34;:&#34;0&#34;}" data-image-title="word-image" data-image-description="" data-image-caption="" data-medium-file="https://static.euromaidanpress.com/wp-content/uploads/2022/03/word-image-17-300x197.png" data-large-file="https://static.euromaidanpress.com/wp-content/uploads/2022/03/word-image-17.png" aria-describedby="caption-attachment-160613" loading="lazy" class="wp-image-160613" src="https://static.euromaidanpress.com/wp-content/uploads/2022/03/word-image-17.png" alt="Screenshot showing that the Russian FSB website is not working. 1 March, 16:47 EET. Source: Mykhailo Fedorov, Minister of Digital Transformation of Ukraine ~" width="977" height="643" srcset="https://static.euromaidanpress.com/wp-content/uploads/2022/03/word-image-17.png 977w, https://static.euromaidanpress.com/wp-content/uploads/2022/03/word-image-17-300x197.png 300w" sizes="(max-width: 977px) 100vw, 977px" /><p id="caption-attachment-160613" class="wp-caption-text">Screenshot showing that the Russian FSB website is not working. 1 March, 16:47 EET. Source: <a href="https://www.facebook.com/photo.php?fbid=1007319886552197&amp;set=pb.100018225866290.-2207520000..&amp;type=3">Mykhailo Fedorov</a>, Minister of Digital Transformation of Ukraine</p></div>
<p>Nikonov added that other developments of Systematics were disabled – significantly the electronic document management systems of Russia in the territory of the Autonomous Republic of Crimea, as well as in the so-called “DNR” and “LNR”:</p>
<blockquote><p>“<em>All files from the servers have been downloaded and already transferred to our law enforcement agencies for analysis and inclusion in the materials of criminal cases against officials of the aggressor country, as well as leaders of the so-called “D/LNR” and their henchmen. Thanks to these materials, Ukrainian law enforcement officers now know for sure every scumbag who took part in the annexation of Crimea and in terrorist acts in eastern Ukraine</em>.”</p></blockquote>
<p>In addition, on 25 February, the management system of the Federal Treasury of the Russian Federation <a href="https://www.facebook.com/1352890141/posts/10227083907027571/">was</a> destroyed, which led to disruption of the basic mechanisms and instruments of financing the army, law enforcement agencies, executive authorities, and state-owned enterprises.</p><div id="ezoic-pub-ad-placeholder-120" data-inserter-version="2"></div>
<h3 id="rtoc-3">What about Russian attacks?</h3>
<p>According to a Ukrainian senior cyber official, the government was <a href="https://www.independent.co.uk/tech/russia-cyber-attack-ukraine-anonymous-b2025500.html">prepared</a> for a Russian invasion cyber attack for days. All sensitive data was to be <a href="https://www.politico.com/news/2022/02/22/ukraine-centralized-its-data-after-the-last-russian-invasion-now-it-may-need-to-evacuate-it-00010777">transferred</a> on 22 February out of Kyiv, should Russian troops move to seize the capital.</p>
<p>However, during the week of the Russian invasion, as an article in the <a href="https://www.economist.com/europe/2022/03/01/cyber-attacks-on-ukraine-are-conspicuous-by-their-absence">Economist</a> put it, cyber attacks by Russian hackers were “<em>conspicuous by their absence.</em>”</p>
<p>The article mentioned previous successful Russian attacks in Ukraine. In 2015, Russian hackers managed to knock out power for some 230,000 customers in the west of Ukraine. In 2017, the Russian attack dubbed “NotPetia” disrupted Ukrainian airports, railways, and banks. This suggests that Russia has a vast capacity for cyberattacks. According to an analysis of <a href="https://twitter.com/MalwareTechBlog/status/1498616107875246086">leaked</a> bitcoin addresses,<strong> Conti ransomware</strong>, which is associated with Russia’s intelligence service, has ratched up at least $2.7 billion since its inception in 2017.</p>
<div class="tmnf-sc-box normal   ">There are several possible explanations as to why Russian massive cyber-attacks are not underway. <a href="https://www.economist.com/europe/2022/03/01/cyber-attacks-on-ukraine-are-conspicuous-by-their-absence">One</a> is that Russia relies on Ukrainian infrastructure and information systems to carry out attacks. In other words, they rely on Ukrainian networks.</div>
<p>Russia also spreads propaganda through the internet. For example, as of 1 March, the Ministry of Defence of Ukraine has been <a href="https://www.facebook.com/SecurSerUkraine/posts/308609431365974">warning</a> Ukrainians about large-scale Russian disinformation campaigns using fake news and videos about an impending capitulation by Ukraine. During 1-2 March, people in different regions of Ukraine reported frequent disruptions in their internet connection.</p>
<p>Experts agree that Russia’s cyberattacks are fewer than were expected, although the interpretations differ. Senate Intelligence Committee Chairman Mark Warner <a href="https://www.independent.co.uk/tech/russia-cyber-attack-ukraine-anonymous-b2025500.html">said</a> 28 February:</p><div id="ezoic-pub-ad-placeholder-121" data-inserter-version="2"></div>
<blockquote><p>“<em>I’ve been pleasantly surprised so far… that Russia has not launched more major cyber attacks against Ukraine. Do I expect Russia to up its game on cyber? Absolutely.</em>”</p></blockquote>
<p>The <a href="https://www.economist.com/europe/2022/03/01/cyber-attacks-on-ukraine-are-conspicuous-by-their-absence">Economist</a> article suggests that one reason attacks are not occurring is that Ukrainian digital defenses are stronger than presumed. It is also possible that decentralized hacker group attacks, like those of Anonymous, take time for Russian hackers to resolve. As the Economist author concludes:</p>
<blockquote><p>“<em>One of the problems with cyber attacks is that it is often hard to be sure.</em>”</p></blockquote>
<h4 id="rtoc-4">Related:</h4>
<ul>
<li class="post entry-title"><em><strong><a href="https://euromaidanpress.com/2022/01/14/ukraine-under-massive-cyberattack-with-a-russian-trace/?swcfpc=1">Ukrainian official sites under massive cyberattack with a Russian trace</a> (January 2022)</strong></em></li>
<li class="post entry-title"><em><strong><a href="https://euromaidanpress.com/2022/01/18/ukraines-security-service-says-it-neutralized-over-2000-cyberattacks-in-2021/?swcfpc=1">Ukraine’s Security Service says it neutralized over 2,000 cyberattacks in 2021</a></strong></em></li>
<li class="post entry-title"><em><strong><a href="https://euromaidanpress.com/2022/02/10/is-ukraine-ready-for-future-cyberattacks-dont-hold-your-breath-experts-say/?swcfpc=1">Is Ukraine ready for future cyberattacks? Don’t hold your breath, experts say </a>(2022)</strong></em></li>
<li class="post entry-title"><em><strong><a href="https://euromaidanpress.com/2022/01/27/strengthening-the-security-resilience-of-ukraine-military-energy-cyber/?swcfpc=1">Strengthening the security resilience of Ukraine: military, energy, cyber </a></strong></em></li>
</ul>
<div class="h4 meta author">
<div class="meta editor">Edited by: Sonia Maryn</div>
</div>
<div id="pa_banner_code"><div style="color: #555555; padding: 1em; border: 1px dotted #dedede; background: #ffffce;">
<strong>Ukraine needs independent journalism. And we need you. </strong>
Join our community on Patreon and help us better connect Ukraine to the world. We’ll use your contribution to attract new authors, upgrade our website, and optimize its SEO.
For as little as the cost of one cup of coffee a month, you can help build bridges between Ukraine and the rest of the world, plus become a co-creator and vote for topics we should cover next. <a href="https://www.patreon.com/euromaidanpress"><b>Become a patron </b></a>or see other ways to <span style="font-weight: 700 !important;"><a href="https://euromaidanpress.com/donate/">support</a>.</span>
<a href="https://www.patreon.com/bePatron?u=36526209" data-patreon-widget-type="become-patron-button">Become a Patron!</a><script async="" src="https://c6.patreon.com/becomePatronButton.bundle.js"></script>
</div></div><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-160604" class="share-facebook sd-button share-icon no-text" href="https://euromaidanpress.com/2022/03/04/international-cyberoffensive-gives-russia-a-sip-of-its-own-bitter-medicine/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-160604" class="share-twitter sd-button share-icon no-text" href="https://euromaidanpress.com/2022/03/04/international-cyberoffensive-gives-russia-a-sip-of-its-own-bitter-medicine/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon no-text" href="https://euromaidanpress.com/2022/03/04/international-cyberoffensive-gives-russia-a-sip-of-its-own-bitter-medicine/?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-160604" class="share-linkedin sd-button share-icon no-text" href="https://euromaidanpress.com/2022/03/04/international-cyberoffensive-gives-russia-a-sip-of-its-own-bitter-medicine/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon no-text" href="https://euromaidanpress.com/2022/03/04/international-cyberoffensive-gives-russia-a-sip-of-its-own-bitter-medicine/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-pocket"><a rel="nofollow noopener noreferrer" data-shared="" class="share-pocket sd-button share-icon no-text" href="https://euromaidanpress.com/2022/03/04/international-cyberoffensive-gives-russia-a-sip-of-its-own-bitter-medicine/?share=pocket" target="_blank" title="Click to share on Pocket"><span></span><span class="sharing-screen-reader-text">Click to share on Pocket (Opens in new window)</span></a></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-160604" class="share-pinterest sd-button share-icon no-text" href="https://euromaidanpress.com/2022/03/04/international-cyberoffensive-gives-russia-a-sip-of-its-own-bitter-medicine/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon no-text" href="https://euromaidanpress.com/2022/03/04/international-cyberoffensive-gives-russia-a-sip-of-its-own-bitter-medicine/#print" target="_blank" title="Click to print"><span></span><span class="sharing-screen-reader-text">Click to print (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div><div class="code-block code-block-1" style="margin: 8px auto; text-align: center; display: block; clear: both;">


</div>


<p>Tags: <a href="https://euromaidanpress.com/tags/cyber-attacks/" rel="tag">cyber attacks</a>, <a href="https://euromaidanpress.com/tags/cybersecurity/" rel="tag">cybersecurity</a>, <a href="https://euromaidanpress.com/tags/cyberwar/" rel="tag">cyberwar</a></p><div id="jp-relatedposts" class="jp-relatedposts">
<div class="widgetable" style=" padding:0; border:0; background:transparent"><div class="h2 widget" style="font: 300 16px/1.2em &#39;Roboto Slab&#39; !important">Related articles</div></div>
</div>
<div class="clearfix"></div>
</div>
<div class="clearfix"></div>
</div>
</article>
<div id="sidebar" class="fourcol">
<div class="postinfo gradient-light">
<div class="cleafix"></div>
<div class="postauthor vcard author" itemprop="author" itemscope="" itemtype="http://schema.org/Person">
<img data-del="avatar" src="https://static.euromaidanpress.com/wp-content/uploads/2022/03/orysya-hrudka-300x300.png" class="avatar pp-user-avatar avatar-75 photo " height="75" width="75" /> <div class="h4">About the Source</div>
<div class="h3" class="additional" itemprop="name"><a href="https://euromaidanpress.com/author/orysia/" itemprop="url">Orysia Hrudka</a>
</div>
<div class="authordesc">Orysia Hrudka is a journalist, book reviewer, researcher, and communications manager for Krytyka Journal and Publishing House. She does her research on the public impact of social media, particularly Facebook, and mentors kids’ projects at Agents of Change school.</div>
</div>
<div class="cleafix"></div>
<span class="bread">
<a href="https://euromaidanpress.com"><i class="fa fa-home"></i> </a> » <a href="https://euromaidanpress.com/category/international/" rel="category tag">International</a>, <a href="https://euromaidanpress.com/category/russian-aggression/" rel="category tag">Russian Aggression</a> » International cyberoffensive gives Russia “a sip... </span>
<div class="clearfix"></div>
<span>
<i class="icon-chevron-sign-left"></i> Previous post:<br />
<a href="https://euromaidanpress.com/2022/03/04/war-in-ukraine-day-9-for-the-first-time-in-history-fighting-around-nuclear-power-plants/" rel="prev">War in Ukraine, Day 9: for the first time in history, fighting around nuclear power plants</a> </span>
<span>
Next Post: <i class="icon-chevron-sign-right"></i><br />
<a href="https://euromaidanpress.com/2022/03/04/international-sanctions-slam-russias-finance-economy-culture-sports-a-list/" rel="next">International sanctions slam Russia’s finance, economy, culture, sports: a list</a> </span>

<ul class="related">
<li><div class="h3">Related Posts</div></li>
<li>
<a href="https://euromaidanpress.com/2022/02/10/is-ukraine-ready-for-future-cyberattacks-dont-hold-your-breath-experts-say/" title="Read the article ”Is Ukraine ready for future cyberattacks? Don’t hold your breath, experts...”">
<img width="186" height="104" src="https://static.euromaidanpress.com/wp-content/uploads/2022/01/SBU_Cyberattack_Ukraine-e1642533272323.jpg" class="attachment-related size-related wp-post-image" alt="Ukraine cyberattacks" loading="lazy" title="" data-attachment-id="158052" data-permalink="https://euromaidanpress.com/2022/01/18/ukraines-security-service-says-it-neutralized-over-2000-cyberattacks-in-2021/sbu_cyberattack_ukraine/" data-orig-file="https://static.euromaidanpress.com/wp-content/uploads/2022/01/SBU_Cyberattack_Ukraine-e1642533272323.jpg" data-orig-size="750,419" data-comments-opened="0" data-image-meta="{&#34;aperture&#34;:&#34;0&#34;,&#34;credit&#34;:&#34;&#34;,&#34;camera&#34;:&#34;&#34;,&#34;caption&#34;:&#34;&#34;,&#34;created_timestamp&#34;:&#34;0&#34;,&#34;copyright&#34;:&#34;&#34;,&#34;focal_length&#34;:&#34;0&#34;,&#34;iso&#34;:&#34;0&#34;,&#34;shutter_speed&#34;:&#34;0&#34;,&#34;title&#34;:&#34;&#34;,&#34;orientation&#34;:&#34;0&#34;}" data-image-title="SBU_Cyberattack_Ukraine" data-image-description="" data-image-caption="&lt;p&gt;Ukraine’s Security Service at work against cybercrimes. Photo: Ssu.gov.ua&lt;/p&gt;
" data-medium-file="https://static.euromaidanpress.com/wp-content/uploads/2022/01/SBU_Cyberattack_Ukraine-200x300.jpg" data-large-file="https://static.euromaidanpress.com/wp-content/uploads/2022/01/SBU_Cyberattack_Ukraine-682x1024.jpg" />
</a>
<div class="h4"><a href="https://euromaidanpress.com/2022/02/10/is-ukraine-ready-for-future-cyberattacks-dont-hold-your-breath-experts-say/" title="Open the article Is Ukraine ready for future cyberattacks? Don’t hold your breath, experts say">Is Ukraine ready for future cyberattacks? Don’t hold...</a></div>
</li>
<li>
<a href="https://euromaidanpress.com/2022/01/18/ukraines-security-service-says-it-neutralized-over-2000-cyberattacks-in-2021/" title="Read the article ”Ukraine’s Security Service says it neutralized over 2,000 cyberattacks in 2021”">
<img width="186" height="104" src="https://static.euromaidanpress.com/wp-content/uploads/2022/01/SBU_Cyberattack_Ukraine-e1642533272323.jpg" class="attachment-related size-related wp-post-image" alt="Ukraine cyberattacks" loading="lazy" title="" data-attachment-id="158052" data-permalink="https://euromaidanpress.com/2022/01/18/ukraines-security-service-says-it-neutralized-over-2000-cyberattacks-in-2021/sbu_cyberattack_ukraine/" data-orig-file="https://static.euromaidanpress.com/wp-content/uploads/2022/01/SBU_Cyberattack_Ukraine-e1642533272323.jpg" data-orig-size="750,419" data-comments-opened="0" data-image-meta="{&#34;aperture&#34;:&#34;0&#34;,&#34;credit&#34;:&#34;&#34;,&#34;camera&#34;:&#34;&#34;,&#34;caption&#34;:&#34;&#34;,&#34;created_timestamp&#34;:&#34;0&#34;,&#34;copyright&#34;:&#34;&#34;,&#34;focal_length&#34;:&#34;0&#34;,&#34;iso&#34;:&#34;0&#34;,&#34;shutter_speed&#34;:&#34;0&#34;,&#34;title&#34;:&#34;&#34;,&#34;orientation&#34;:&#34;0&#34;}" data-image-title="SBU_Cyberattack_Ukraine" data-image-description="" data-image-caption="&lt;p&gt;Ukraine’s Security Service at work against cybercrimes. Photo: Ssu.gov.ua&lt;/p&gt;
" data-medium-file="https://static.euromaidanpress.com/wp-content/uploads/2022/01/SBU_Cyberattack_Ukraine-200x300.jpg" data-large-file="https://static.euromaidanpress.com/wp-content/uploads/2022/01/SBU_Cyberattack_Ukraine-682x1024.jpg" />
</a>
<div class="h4"><a href="https://euromaidanpress.com/2022/01/18/ukraines-security-service-says-it-neutralized-over-2000-cyberattacks-in-2021/" title="Open the article Ukraine’s Security Service says it neutralized over 2,000 cyberattacks in 2021">Ukraine’s Security Service says it neutralized over 2,000...</a></div>
</li>
<li>
<a href="https://euromaidanpress.com/2022/01/14/ukraine-under-massive-cyberattack-with-a-russian-trace/" title="Read the article ”Ukrainian official sites under massive cyberattack with a Russian trace”">
<img width="186" height="104" src="https://static.euromaidanpress.com/wp-content/uploads/2022/01/cyberattack.jpg" class="attachment-related size-related wp-post-image" alt="cyberattack ukraine hacker" loading="lazy" title="" srcset="https://static.euromaidanpress.com/wp-content/uploads/2022/01/cyberattack.jpg 640w, https://static.euromaidanpress.com/wp-content/uploads/2022/01/cyberattack-300x168.jpg 300w" sizes="(max-width: 186px) 100vw, 186px" data-attachment-id="157891" data-permalink="https://euromaidanpress.com/2022/01/14/ukraine-under-massive-cyberattack-with-a-russian-trace/one-attack-null-cyber-encryption-smartphone/" data-orig-file="https://static.euromaidanpress.com/wp-content/uploads/2022/01/cyberattack.jpg" data-orig-size="640,358" data-comments-opened="0" data-image-meta="{&#34;aperture&#34;:&#34;0&#34;,&#34;credit&#34;:&#34;https:\/\/www.maxpixel.net\/One-Attack-Null-Cyber-Encryption-Smartphone-4444450&#34;,&#34;camera&#34;:&#34;&#34;,&#34;caption&#34;:&#34;One Attack Null Cyber Encryption Smartphone&#34;,&#34;created_timestamp&#34;:&#34;0&#34;,&#34;copyright&#34;:&#34;Copyright by MaxPixel&#34;,&#34;focal_length&#34;:&#34;0&#34;,&#34;iso&#34;:&#34;0&#34;,&#34;shutter_speed&#34;:&#34;0&#34;,&#34;title&#34;:&#34;One Attack Null Cyber Encryption Smartphone&#34;,&#34;orientation&#34;:&#34;0&#34;}" data-image-title="cyberattack ukraine hacker" data-image-description="" data-image-caption="&lt;p&gt;Credit: maxpixel.net&lt;/p&gt;
" data-medium-file="https://static.euromaidanpress.com/wp-content/uploads/2022/01/cyberattack-300x168.jpg" data-large-file="https://static.euromaidanpress.com/wp-content/uploads/2022/01/cyberattack.jpg" />
</a>
<div class="h4"><a href="https://euromaidanpress.com/2022/01/14/ukraine-under-massive-cyberattack-with-a-russian-trace/" title="Open the article Ukrainian official sites under massive cyberattack with a Russian trace">Ukrainian official sites under massive cyberattack with a...</a></div>
</li>
<li>
<a href="https://euromaidanpress.com/2020/10/16/ukraine-to-cooperate-with-us-sanctioned-huawei-in-cybersecurity-not/" title="Read the article ”Ukraine to cooperate with US-sanctioned Huawei in cybersecurity. Not?”">
<img width="186" height="124" src="https://static.euromaidanpress.com/wp-content/uploads/2020/10/derzhspeczvyazok-spivpracyuvatime-z-kompan...-1.jpeg" class="attachment-related size-related wp-post-image" alt="Держспецзв&#39;язок співпрацюватиме з компан…" loading="lazy" title="" srcset="https://static.euromaidanpress.com/wp-content/uploads/2020/10/derzhspeczvyazok-spivpracyuvatime-z-kompan...-1.jpeg 745w, https://static.euromaidanpress.com/wp-content/uploads/2020/10/derzhspeczvyazok-spivpracyuvatime-z-kompan...-1-300x200.jpeg 300w" sizes="(max-width: 186px) 100vw, 186px" data-attachment-id="143153" data-permalink="https://euromaidanpress.com/2020/10/16/ukraine-to-cooperate-with-us-sanctioned-huawei-in-cybersecurity-not/derzhspeczvyazok-spivpracyuvatime-z-kompan-2/" data-orig-file="https://static.euromaidanpress.com/wp-content/uploads/2020/10/derzhspeczvyazok-spivpracyuvatime-z-kompan...-1.jpeg" data-orig-size="745,497" data-comments-opened="0" data-image-meta="{&#34;aperture&#34;:&#34;0&#34;,&#34;credit&#34;:&#34;&#34;,&#34;camera&#34;:&#34;&#34;,&#34;caption&#34;:&#34;&#34;,&#34;created_timestamp&#34;:&#34;0&#34;,&#34;copyright&#34;:&#34;&#34;,&#34;focal_length&#34;:&#34;0&#34;,&#34;iso&#34;:&#34;0&#34;,&#34;shutter_speed&#34;:&#34;0&#34;,&#34;title&#34;:&#34;&#34;,&#34;orientation&#34;:&#34;0&#34;}" data-image-title="derzhspeczvyazok-spivpracyuvatime-z-kompan…" data-image-description="" data-image-caption="&lt;p&gt;Heads of Derzhspetszviazok and Huawei Ukraine signing a memorandum on cooperation. Kyiv, 15 October 2020. Photo: facebook.com/derzhspeczvyazku&lt;/p&gt;
" data-medium-file="https://static.euromaidanpress.com/wp-content/uploads/2020/10/derzhspeczvyazok-spivpracyuvatime-z-kompan...-1-300x200.jpeg" data-large-file="https://static.euromaidanpress.com/wp-content/uploads/2020/10/derzhspeczvyazok-spivpracyuvatime-z-kompan...-1.jpeg" />
</a>
<div class="h4"><a href="https://euromaidanpress.com/2020/10/16/ukraine-to-cooperate-with-us-sanctioned-huawei-in-cybersecurity-not/" title="Open the article Ukraine to cooperate with US-sanctioned Huawei in cybersecurity. Not?">Ukraine to cooperate with US-sanctioned Huawei in cybersecurity....</a></div>
</li>
</ul>
<div class="clearfix"></div>
</div>
<div class="clearfix"></div>
<div class="widgetable">
<div id="ezoic-pub-ad-placeholder-106" data-inserter-version="-1"></div><div class="h2 widget">Advertisement</div><div class="code-block code-block-6" style="margin: 8px 0; clear: both;">

<div style="overflow: visible">
<div style="transform: scale(0.93); width:300px; position:relative;left:-9px">


</div>
</div></div>
<div id="ezoic-pub-ad-placeholder-107" data-inserter-version="-1"></div><div class="h2 widget">Subscribe to the weekly newsletter</div><script>(function() {
	window.mc4wp = window.mc4wp || {
		listeners: [],
		forms: {
			on: function(evt, cb) {
				window.mc4wp.listeners.push(
					{
						event   : evt,
						callback: cb
					}
				);
			}
		}
	}
})();
</script><form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-113114" method="post" data-id="113114" data-name="Newsletter"><div class="mc4wp-form-fields">

<link href="//cdn-images.mailchimp.com/embedcode/classic-10_7.css" rel="stylesheet" />
<style>
	#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif; }
	/* Add your own Mailchimp form style overrides in your site stylesheet or in this style block.
	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style>
<div id="mc_embed_signup">
<div id="mc_embed_signup_scroll">
<div class="indicates-required"><span class="asterisk">*</span> indicates required</div>
<div class="mc-field-group">
<label for="mce-EMAIL">Email Address <span class="asterisk">*</span>
</label>
<input type="email" value="" name="EMAIL" class="required email" id="mce-EMAIL" />
</div>
<div class="mc-field-group">
<label for="mce-FNAME">First Name </label>
<input type="text" value="" name="FNAME" class="" id="mce-FNAME" />
</div>
<div class="mc-field-group">
<label for="mce-LNAME">Last Name </label>
<input type="text" value="" name="LNAME" class="" id="mce-LNAME" />
</div>
<div class="mc-field-group input-group">
<strong>Type of mailing list </strong>
<ul><li><input type="checkbox" value="1" name="group[37625][1]" id="mce-group[37625]-37625-0" /><label for="mce-group[37625]-37625-0">News and analysis highlights</label></li>
<li><input type="checkbox" value="2" name="group[37625][2]" id="mce-group[37625]-37625-1" /><label for="mce-group[37625]-37625-1">Let My People Go</label></li>
<li><input type="checkbox" value="4" name="group[37625][4]" id="mce-group[37625]-37625-2" /><label for="mce-group[37625]-37625-2">Friends of Ukraine Network</label></li>
</ul>
</div>
<div id="mce-responses" class="clear">
<div class="response" id="mce-error-response" style="display:none"></div>
<div class="response" id="mce-success-response" style="display:none"></div>
</div> 
<div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_7bdde59c3f36a3071ebc921b3_ea25448903" tabindex="-1" value="" /></div>
<div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button" /></div>
</div>
</div>
<script src="//s3.amazonaws.com/downloads.mailchimp.com/js/mc-validate.js"></script><script>(function($) {window.fnames = new Array(); window.ftypes = new Array();fnames[0]='EMAIL';ftypes[0]='email';fnames[1]='FNAME';ftypes[1]='text';fnames[2]='LNAME';ftypes[2]='text';fnames[3]='ADDRESS';ftypes[3]='address';fnames[4]='PHONE';ftypes[4]='phone';fnames[5]='MMERGE5';ftypes[5]='text';fnames[6]='MMERGE6';ftypes[6]='text';fnames[7]='MMERGE7';ftypes[7]='text';fnames[8]='MMERGE8';ftypes[8]='text';fnames[9]='MMERGE9';ftypes[9]='text';fnames[10]='MMERGE10';ftypes[10]='text';fnames[11]='MMERGE11';ftypes[11]='text';fnames[12]='MMERGE12';ftypes[12]='text';fnames[13]='MMERGE13';ftypes[13]='text';fnames[14]='MMERGE14';ftypes[14]='text';fnames[15]='MMERGE15';ftypes[15]='text';}(jQuery));var $mcj = jQuery.noConflict(true);</script>

</div><label style="display: none !important;">Leave this field empty if you&#39;re human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></label><input type="hidden" name="_mc4wp_timestamp" value="1646406939" /><input type="hidden" name="_mc4wp_form_id" value="113114" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1" /><div class="mc4wp-response"></div></form><div id="ezoic-pub-ad-placeholder-108" data-inserter-version="-1"></div>
<div class="h2 widget"><a href="https://euromaidanpress.com/category/zorro/featured/">Featured</a></div>
<ul class="featured gradient-light">
<li class="bloglike">
<div class="imgwrap">
<a href="https://euromaidanpress.com/2022/03/02/how-to-join-ukraines-foreign-legion-of-territorial-defense-step-by-step/" title="Read the article ”How to join Ukraine’s Foreign Legion...”">
<img width="362" height="320" src="https://static.euromaidanpress.com/wp-content/uploads/2022/03/chevron-zsu-362x320.jpeg" class="attachment-blog-big size-blog-big wp-post-image" alt="How to join Ukraine’s Foreign Legion of Territorial Defense" loading="lazy" data-attachment-id="160528" data-permalink="https://euromaidanpress.com/2022/03/02/how-to-join-ukraines-foreign-legion-of-territorial-defense-step-by-step/chevron-zsu/" data-orig-file="https://static.euromaidanpress.com/wp-content/uploads/2022/03/chevron-zsu.jpeg" data-orig-size="786,524" data-comments-opened="0" data-image-meta="{&#34;aperture&#34;:&#34;0&#34;,&#34;credit&#34;:&#34;&#34;,&#34;camera&#34;:&#34;&#34;,&#34;caption&#34;:&#34;&#34;,&#34;created_timestamp&#34;:&#34;0&#34;,&#34;copyright&#34;:&#34;&#34;,&#34;focal_length&#34;:&#34;0&#34;,&#34;iso&#34;:&#34;0&#34;,&#34;shutter_speed&#34;:&#34;0&#34;,&#34;title&#34;:&#34;&#34;,&#34;orientation&#34;:&#34;0&#34;}" data-image-title="chevron zsu" data-image-description="" data-image-caption="&lt;p&gt;Chevron of the Ukrainian Armed Forces. Photo: 5.ua&lt;/p&gt;
" data-medium-file="https://static.euromaidanpress.com/wp-content/uploads/2022/03/chevron-zsu-300x200.jpeg" data-large-file="https://static.euromaidanpress.com/wp-content/uploads/2022/03/chevron-zsu.jpeg" />
</a>
</div>
<p class="meta">

<time class="article-timestamp" itemprop="datePublished" datetime="2022-03-02T20:42:21.000+02:00" data-type="updated">
2022/03/02 - 20:42 •
</time>
<time class="article-timestamp" itemprop="dateModified" datetime="2022-03-03T13:52:55.000+02:00" data-type="updated">
</time>
<a href="https://euromaidanpress.com/category/zorro/featured/" rel="category tag">Featured</a>, <a href="https://euromaidanpress.com/category/russian-aggression/" rel="category tag">Russian Aggression</a>
</p>
<span itemprop="publisher" itemscope="" itemtype="https://schema.org/Organization">
<meta itemprop="name" content="Euromaidan Press" />
<span itemprop="logo" itemscope="" itemtype="https://schema.org/ImageObject">
<meta itemprop="url" content="https://euromaidanpress.com/wp-content/uploads/2017/07/logo_gn.png" />
<meta itemprop="width" content="467" />
<meta itemprop="height" content="91" />
</span>
</span>
<div class="h3"><a href="https://euromaidanpress.com/2022/03/02/how-to-join-ukraines-foreign-legion-of-territorial-defense-step-by-step/" title="How to join Ukraine’s Foreign Legion of Territorial Defense"> How to join Ukraine’s Foreign Legion of Territorial Defense</a></div>
<p class="teaser">The hotline for foreign volunteers wishing to help Ukraine is now running. The number to call is +380442370002, and press ‘2’ for English. Algorithm for foreigners to join the Foreign Legion of Territorial Defense of Ukraine...</p>
<p class="meta_more">
<a href="https://euromaidanpress.com/2022/03/02/how-to-join-ukraines-foreign-legion-of-territorial-defense-step-by-step/">Read article</a>
</p>
</li>
</ul>
<div style="clear: both;"></div>
<div id="ezoic-pub-ad-placeholder-109" data-inserter-version="-1"></div><div class="h2 widget">SUPPORT US: BECOME A PATRON</div> <div class="textwidget"><p><a href="https://euromaidanpress.com/join-the-club-become-a-euromaidan-press-patron/?"><img loading="lazy" class="aligncenter size-full wp-image-144275" src="https://euromaidanpress.com/wp-content/uploads/2020/11/patron3.jpg" alt="" width="338" height="291" srcset="https://static.euromaidanpress.com/wp-content/uploads/2020/11/patron3.jpg 338w, https://static.euromaidanpress.com/wp-content/uploads/2020/11/patron3-300x258.jpg 300w" sizes="(max-width: 338px) 100vw, 338px" /></a></p>
</div>
<div class="h2 widget">Recent posts</div>
<ul>
<li>
<a href="https://euromaidanpress.com/2022/03/04/what-the-west-should-do-to-prevent-a-humanitarian-crisis-in-ukraine/">What the West should do to prevent a humanitarian crisis in Ukraine</a>
<span class="post-date">2022/03/04 - 17:04</span>
</li>
<li>
<a href="https://euromaidanpress.com/2022/03/04/international-sanctions-slam-russias-finance-economy-culture-sports-a-list/">International sanctions slam Russia’s finance, economy, culture, sports: a list</a>
<span class="post-date">2022/03/04 - 16:18</span>
</li>
<li>
<a href="https://euromaidanpress.com/2022/03/04/international-cyberoffensive-gives-russia-a-sip-of-its-own-bitter-medicine/" aria-current="page">International cyberoffensive gives Russia “a sip of its own bitter medicine”</a>
<span class="post-date">2022/03/04 - 14:51</span>
</li>
<li>
<a href="https://euromaidanpress.com/2022/03/04/war-in-ukraine-day-9-for-the-first-time-in-history-fighting-around-nuclear-power-plants/">War in Ukraine, Day 9: for the first time in history, fighting around nuclear power plants</a>
<span class="post-date">2022/03/04 - 12:42</span>
</li>
<li>
<a href="https://euromaidanpress.com/2022/03/03/putins-ruin/">putin’s ruin</a>
<span class="post-date">2022/03/03 - 15:13</span>
</li>
</ul>
<div class="h2 widget">Advertisement</div><div class="code-block code-block-2" style="margin: 8px auto; text-align: center; display: block; clear: both;">

<div id="stick-here"></div>
</div>
<div id="ezoic-pub-ad-placeholder-110" data-inserter-version="-1"></div><div id="ezoic-pub-ad-placeholder-111" data-inserter-version="-1"></div>
</div>
</div>
</div>
</div>

</div><div class="clerfix"></div>
<div id="footer" class="body2 ">
<div class="container">
<div class="threecol first">
<div class="h2 widget">Recent Articles</div>
<ul>
<li>
<a href="https://euromaidanpress.com/2022/03/04/what-the-west-should-do-to-prevent-a-humanitarian-crisis-in-ukraine/">What the West should do to prevent a humanitarian crisis in Ukraine</a>
</li>
<li>
<a href="https://euromaidanpress.com/2022/03/04/international-sanctions-slam-russias-finance-economy-culture-sports-a-list/">International sanctions slam Russia’s finance, economy, culture, sports: a list</a>
</li>
<li>
<a href="https://euromaidanpress.com/2022/03/04/international-cyberoffensive-gives-russia-a-sip-of-its-own-bitter-medicine/" aria-current="page">International cyberoffensive gives Russia “a sip of its own bitter medicine”</a>
</li>
<li>
<a href="https://euromaidanpress.com/2022/03/04/war-in-ukraine-day-9-for-the-first-time-in-history-fighting-around-nuclear-power-plants/">War in Ukraine, Day 9: for the first time in history, fighting around nuclear power plants</a>
</li>
<li>
<a href="https://euromaidanpress.com/2022/03/03/putins-ruin/">putin’s ruin</a>
</li>
</ul>
</div>
<div class="threecol">
</div>
<div class="threecol">
<div class="h2 widget">Subscribe to the newsletter</div><script>(function() {
	window.mc4wp = window.mc4wp || {
		listeners: [],
		forms: {
			on: function(evt, cb) {
				window.mc4wp.listeners.push(
					{
						event   : evt,
						callback: cb
					}
				);
			}
		}
	}
})();
</script><form id="mc4wp-form-2" class="mc4wp-form mc4wp-form-113114" method="post" data-id="113114" data-name="Newsletter"><div class="mc4wp-form-fields">

<link href="//cdn-images.mailchimp.com/embedcode/classic-10_7.css" rel="stylesheet" />
<style>
	#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif; }
	/* Add your own Mailchimp form style overrides in your site stylesheet or in this style block.
	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style>
<div id="mc_embed_signup">
<div id="mc_embed_signup_scroll">
<div class="indicates-required"><span class="asterisk">*</span> indicates required</div>
<div class="mc-field-group">
<label for="mce-EMAIL">Email Address <span class="asterisk">*</span>
</label>
<input type="email" value="" name="EMAIL" class="required email" id="mce-EMAIL" />
</div>
<div class="mc-field-group">
<label for="mce-FNAME">First Name </label>
<input type="text" value="" name="FNAME" class="" id="mce-FNAME" />
</div>
<div class="mc-field-group">
<label for="mce-LNAME">Last Name </label>
<input type="text" value="" name="LNAME" class="" id="mce-LNAME" />
</div>
<div class="mc-field-group input-group">
<strong>Type of mailing list </strong>
<ul><li><input type="checkbox" value="1" name="group[37625][1]" id="mce-group[37625]-37625-0" /><label for="mce-group[37625]-37625-0">News and analysis highlights</label></li>
<li><input type="checkbox" value="2" name="group[37625][2]" id="mce-group[37625]-37625-1" /><label for="mce-group[37625]-37625-1">Let My People Go</label></li>
<li><input type="checkbox" value="4" name="group[37625][4]" id="mce-group[37625]-37625-2" /><label for="mce-group[37625]-37625-2">Friends of Ukraine Network</label></li>
</ul>
</div>
<div id="mce-responses" class="clear">
<div class="response" id="mce-error-response" style="display:none"></div>
<div class="response" id="mce-success-response" style="display:none"></div>
</div> 
<div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_7bdde59c3f36a3071ebc921b3_ea25448903" tabindex="-1" value="" /></div>
<div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button" /></div>
</div>
</div>
<script src="//s3.amazonaws.com/downloads.mailchimp.com/js/mc-validate.js"></script><script>(function($) {window.fnames = new Array(); window.ftypes = new Array();fnames[0]='EMAIL';ftypes[0]='email';fnames[1]='FNAME';ftypes[1]='text';fnames[2]='LNAME';ftypes[2]='text';fnames[3]='ADDRESS';ftypes[3]='address';fnames[4]='PHONE';ftypes[4]='phone';fnames[5]='MMERGE5';ftypes[5]='text';fnames[6]='MMERGE6';ftypes[6]='text';fnames[7]='MMERGE7';ftypes[7]='text';fnames[8]='MMERGE8';ftypes[8]='text';fnames[9]='MMERGE9';ftypes[9]='text';fnames[10]='MMERGE10';ftypes[10]='text';fnames[11]='MMERGE11';ftypes[11]='text';fnames[12]='MMERGE12';ftypes[12]='text';fnames[13]='MMERGE13';ftypes[13]='text';fnames[14]='MMERGE14';ftypes[14]='text';fnames[15]='MMERGE15';ftypes[15]='text';}(jQuery));var $mcj = jQuery.noConflict(true);</script>

</div><label style="display: none !important;">Leave this field empty if you&#39;re human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></label><input type="hidden" name="_mc4wp_timestamp" value="1646406939" /><input type="hidden" name="_mc4wp_form_id" value="113114" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-2" /><div class="mc4wp-response"></div></form>
</div>
<div class="threecol">
<div class="textwidget"><p>Copyright © 2021 Euromaidanpress.com</p>
<p>The work of Euromaidan Press is supported by the International Renaissance Foundation<br />
<img loading="lazy" class="alignnone" src="https://euromaidanpress.com/wp-content/uploads/2016/08/renaissanceblack.png" alt="" width="612" height="282" /></p>
</div>
<div class="textwidget"><p>When referencing our materials, please include an active hyperlink to the Euromaidan Press material and a maximum 500-character extract of the story. To reprint anything longer, written permission must be acquired from <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="bdd8c8cfd2d0dcd4d9dcd3cdcfd8cecefddad0dcd4d193ded2d093">[email&#160;protected]</a></p>
<p><a href="https://euromaidanpress.com/privacy-and-cookie-policies/">Privacy and Cookie Policies</a>.</p>
</div>
</div>
<div style="clear:both">
<strong class="h2 widget">Popular Tags</strong>
<div class="center-tagcloud"><ul>
<li><a href="https://euromaidanpress.com/tags/letmypeoplego/" class="tag-cloud-link tag-link-5609 tag-link-position-1" style="font-size: 8.3307086614173pt;" aria-label="#LetMyPeopleGo (199 items)">#LetMyPeopleGo</a>
<a href="https://euromaidanpress.com/tags/archive/" class="tag-cloud-link tag-link-8628 tag-link-position-2" style="font-size: 12.409448818898pt;" aria-label="Archive (462 items)">Archive</a>
<a href="https://euromaidanpress.com/tags/belarus/" class="tag-cloud-link tag-link-5807 tag-link-position-3" style="font-size: 10.755905511811pt;" aria-label="Belarus (333 items)">Belarus</a>
<a href="https://euromaidanpress.com/tags/crimea-articles/" class="tag-cloud-link tag-link-33 tag-link-position-4" style="font-size: 16.488188976378pt;" aria-label="Crimea (1,087 items)">Crimea</a>
<a href="https://euromaidanpress.com/tags/crimean-tatars/" class="tag-cloud-link tag-link-480 tag-link-position-5" style="font-size: 8.992125984252pt;" aria-label="Crimean Tatars (226 items)">Crimean Tatars</a>
<a href="https://euromaidanpress.com/tags/deutsch/" class="tag-cloud-link tag-link-8632 tag-link-position-6" style="font-size: 14.944881889764pt;" aria-label="Deutsch (793 items)">Deutsch</a>
<a href="https://euromaidanpress.com/tags/disinformation/" class="tag-cloud-link tag-link-6168 tag-link-position-7" style="font-size: 9.9842519685039pt;" aria-label="disinformation (283 items)">disinformation</a>
<a href="https://euromaidanpress.com/tags/dnr-donetsk-peoples-republic/" class="tag-cloud-link tag-link-8329 tag-link-position-8" style="font-size: 8.1102362204724pt;" aria-label="DNR (“Donetsk People’s Republic”) (190 items)">DNR (“Donetsk People’s Republic”)</a>
<a href="https://euromaidanpress.com/tags/donbas/" class="tag-cloud-link tag-link-58 tag-link-position-9" style="font-size: 15.385826771654pt;" aria-label="Donbas (878 items)">Donbas</a>
<a href="https://euromaidanpress.com/tags/donbas-war-2014-present/" class="tag-cloud-link tag-link-2136 tag-link-position-10" style="font-size: 18.031496062992pt;" aria-label="Donbas war (2014-present) (1,503 items)">Donbas war (2014-present)</a>
<a href="https://euromaidanpress.com/tags/donetsk/" class="tag-cloud-link tag-link-59 tag-link-position-11" style="font-size: 9.4330708661417pt;" aria-label="Donetsk (252 items)">Donetsk</a>
<a href="https://euromaidanpress.com/tags/eastern-ukraine/" class="tag-cloud-link tag-link-60 tag-link-position-12" style="font-size: 8.7716535433071pt;" aria-label="Eastern Ukraine (220 items)">Eastern Ukraine</a>
<a href="https://euromaidanpress.com/tags/economy/" class="tag-cloud-link tag-link-93 tag-link-position-13" style="font-size: 8.2204724409449pt;" aria-label="economy (192 items)">economy</a>
<a href="https://euromaidanpress.com/tags/eu/" class="tag-cloud-link tag-link-38 tag-link-position-14" style="font-size: 10.535433070866pt;" aria-label="EU (313 items)">EU</a>
<a href="https://euromaidanpress.com/tags/euromaidan-articles/" class="tag-cloud-link tag-link-39 tag-link-position-15" style="font-size: 13.511811023622pt;" aria-label="EuroMaidan (588 items)">EuroMaidan</a>
<a href="https://euromaidanpress.com/tags/featured/" class="tag-cloud-link tag-link-8629 tag-link-position-16" style="font-size: 10.976377952756pt;" aria-label="Featured (349 items)">Featured</a>
<a href="https://euromaidanpress.com/tags/history/" class="tag-cloud-link tag-link-5803 tag-link-position-17" style="font-size: 12.07874015748pt;" aria-label="History (436 items)">History</a>
<a href="https://euromaidanpress.com/tags/hybrid-warfare/" class="tag-cloud-link tag-link-7749 tag-link-position-18" style="font-size: 9.1023622047244pt;" aria-label="hybrid warfare (233 items)">hybrid warfare</a>
<a href="https://euromaidanpress.com/tags/international/" class="tag-cloud-link tag-link-50 tag-link-position-19" style="font-size: 20.566929133858pt;" aria-label="international (2,553 items)">international</a>
<a href="https://euromaidanpress.com/tags/military-opinion-analysis/" class="tag-cloud-link tag-link-8623 tag-link-position-20" style="font-size: 9.8740157480315pt;" aria-label="Military analysis (277 items)">Military analysis</a>
<a href="https://euromaidanpress.com/tags/nato/" class="tag-cloud-link tag-link-432 tag-link-position-21" style="font-size: 8.7716535433071pt;" aria-label="NATO (217 items)">NATO</a>
<a href="https://euromaidanpress.com/tags/news/" class="tag-cloud-link tag-link-8652 tag-link-position-22" style="font-size: 20.897637795276pt;" aria-label="News (2,734 items)">News</a>
<a href="https://euromaidanpress.com/tags/op-ed/" class="tag-cloud-link tag-link-8624 tag-link-position-23" style="font-size: 10.094488188976pt;" aria-label="Op-ed (288 items)">Op-ed</a>
<a href="https://euromaidanpress.com/tags/petro-poroshenko/" class="tag-cloud-link tag-link-76 tag-link-position-24" style="font-size: 8.7716535433071pt;" aria-label="Petro Poroshenko (216 items)">Petro Poroshenko</a>
<a href="https://euromaidanpress.com/tags/political-prisoners/" class="tag-cloud-link tag-link-4301 tag-link-position-25" style="font-size: 8.4409448818898pt;" aria-label="Political prisoners (205 items)">Political prisoners</a>
<a href="https://euromaidanpress.com/tags/political-news/" class="tag-cloud-link tag-link-8655 tag-link-position-26" style="font-size: 9.1023622047244pt;" aria-label="Politics (236 items)">Politics</a>
<a href="https://euromaidanpress.com/tags/putin/" class="tag-cloud-link tag-link-81 tag-link-position-27" style="font-size: 17.811023622047pt;" aria-label="Putin (1,448 items)">Putin</a>
<a href="https://euromaidanpress.com/tags/putin-regime/" class="tag-cloud-link tag-link-6752 tag-link-position-28" style="font-size: 11.968503937008pt;" aria-label="Putin regime (429 items)">Putin regime</a>
<a href="https://euromaidanpress.com/tags/russia-articles/" class="tag-cloud-link tag-link-52 tag-link-position-29" style="font-size: 22pt;" aria-label="Russia (3,478 items)">Russia</a>
<a href="https://euromaidanpress.com/tags/russias-anschluss-of-crimea/" class="tag-cloud-link tag-link-5551 tag-link-position-30" style="font-size: 8pt;" aria-label="Russia&#39;s Anschluss of Crimea (184 items)">Russia&#39;s Anschluss of Crimea</a>
<a href="https://euromaidanpress.com/tags/russias-confrontation-with-the-west/" class="tag-cloud-link tag-link-6662 tag-link-position-31" style="font-size: 9.6535433070866pt;" aria-label="Russia&#39;s confrontation with the West (265 items)">Russia&#39;s confrontation with the West</a>
<a href="https://euromaidanpress.com/tags/russias-hybrid-war/" class="tag-cloud-link tag-link-6292 tag-link-position-32" style="font-size: 10.866141732283pt;" aria-label="Russia&#39;s hybrid war (341 items)">Russia&#39;s hybrid war</a>
<a href="https://euromaidanpress.com/tags/russian-aggression/" class="tag-cloud-link tag-link-4041 tag-link-position-33" style="font-size: 11.196850393701pt;" aria-label="Russian aggression (363 items)">Russian aggression</a>
<a href="https://euromaidanpress.com/tags/russian-disinformation/" class="tag-cloud-link tag-link-4389 tag-link-position-34" style="font-size: 9.6535433070866pt;" aria-label="Russian disinformation (260 items)">Russian disinformation</a>
<a href="https://euromaidanpress.com/tags/russian-imperialism/" class="tag-cloud-link tag-link-4064 tag-link-position-35" style="font-size: 8.2204724409449pt;" aria-label="Russian imperialism (196 items)">Russian imperialism</a>
<a href="https://euromaidanpress.com/tags/russian-invasion/" class="tag-cloud-link tag-link-36 tag-link-position-36" style="font-size: 13.952755905512pt;" aria-label="Russian invasion (645 items)">Russian invasion</a>
<a href="https://euromaidanpress.com/tags/russian-media/" class="tag-cloud-link tag-link-2067 tag-link-position-37" style="font-size: 8.4409448818898pt;" aria-label="Russian media (204 items)">Russian media</a>
<a href="https://euromaidanpress.com/tags/russian-military-threat/" class="tag-cloud-link tag-link-5638 tag-link-position-38" style="font-size: 8.2204724409449pt;" aria-label="Russian military threat (192 items)">Russian military threat</a>
<a href="https://euromaidanpress.com/tags/russian-propaganda/" class="tag-cloud-link tag-link-462 tag-link-position-39" style="font-size: 14.393700787402pt;" aria-label="Russian propaganda (712 items)">Russian propaganda</a>
<a href="https://euromaidanpress.com/tags/russland/" class="tag-cloud-link tag-link-5806 tag-link-position-40" style="font-size: 10.425196850394pt;" aria-label="Russland (311 items)">Russland</a>
<a href="https://euromaidanpress.com/tags/russo-ukrainian-war-2014-present/" class="tag-cloud-link tag-link-6807 tag-link-position-41" style="font-size: 13.842519685039pt;" aria-label="Russo-Ukrainian War (2014-present) (635 items)">Russo-Ukrainian War (2014-present)</a>
<a href="https://euromaidanpress.com/tags/soviet-history/" class="tag-cloud-link tag-link-5332 tag-link-position-42" style="font-size: 8.4409448818898pt;" aria-label="Soviet history (201 items)">Soviet history</a>
<a href="https://euromaidanpress.com/tags/ukraine/" class="tag-cloud-link tag-link-5804 tag-link-position-43" style="font-size: 18.362204724409pt;" aria-label="Ukraine (1,624 items)">Ukraine</a>
<a href="https://euromaidanpress.com/tags/usa/" class="tag-cloud-link tag-link-143 tag-link-position-44" style="font-size: 8.8818897637795pt;" aria-label="USA (221 items)">USA</a>
<a href="https://euromaidanpress.com/tags/volodymyr-zelenskyy-zelenskyi-zelensky-zelenskiy/" class="tag-cloud-link tag-link-8967 tag-link-position-45" style="font-size: 8.5511811023622pt;" aria-label="Volodymyr Zelenskyy (Zelenskyi / Zelensky / Zelenskiy) (208 items)">Volodymyr Zelenskyy (Zelenskyi / Zelensky / Zelenskiy)</a></li>
</ul></div>
</div>
<div id="copyright">
<div class="fl">
</div>
<div class="fl">
<p>Copyright © 2022 Euromaidan Press </p>
</div>
<div class="fr">
<p>News on the War in Ukraine</p>
</div>
</div> 
</div>
</div>
<div class="scrollTo_top" style="display: block">
<a title="Scroll to top" href="#">
<i class="fa fa-arrow-circle-o-up"></i>
</a>
</div>
<div class="code-block code-block-8" style="margin: 8px 0; clear: both;">
</div>
<div class="code-block code-block-9" style="margin: 8px 0; clear: both;">



<div id="ezoic-pub-ad-placeholder-101"> </div>

</div>

<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>jQuery(function(){omShortcodes.init(["buttons","tooltips","toggle","tabs","responsivebox","counter"]);});</script><script>
//jQuery( document ).ready(function() {
var pledged = 1909;
var goal    = 2000;
function format_Ks(x){
 return x.toString().replace(/\B(?=(\d{3})+(?!\d))/g, ",");
 }
function update_thermometer(value){
	if(value && /^(\d+)\|(\d+)$/.test(value)){
	pledged = parseInt(RegExp.$1);
	goal = parseInt(RegExp.$2);
	}
	if(document.getElementById('donations_progress_bar')){
		document.getElementById('have').style.width = Math.floor(100* pledged * 100 / goal)/100 + '%';
		var to_go = goal - pledged;
		to_go = 0>to_go ? 0 : to_go;
		document.getElementById('text_pledged').innerHTML = "$ " + format_Ks(to_go) + ' still to go!';
		}
	}
update_thermometer();
jQuery(document).ready(function(){
        jQuery.ajax({
          type:'POST',
          data:{action:'get_donation_values'},
          url: "https://euromaidanpress.com/wp-admin/admin-ajax.php",
          success: function(value) {
            update_thermometer(value);
          }
        });
    });
//});
</script>
<script>(function() {function maybePrefixUrlField() {
	if (this.value.trim() !== '' && this.value.indexOf('http') !== 0) {
		this.value = "http://" + this.value;
	}
}

var urlFields = document.querySelectorAll('.mc4wp-form input[type="url"]');
if (urlFields) {
	for (var j=0; j < urlFields.length; j++) {
		urlFields[j].addEventListener('blur', maybePrefixUrlField);
	}
}
})();</script><div class="wppopups-whole" style="display: none"></div><script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-9514651-72', 'auto');
  ga('send', 'pageview');

</script>
<div id="jp-carousel-loading-overlay">
<div id="jp-carousel-loading-wrapper">
<span id="jp-carousel-library-loading"> </span>
</div>
</div>
<div class="jp-carousel-overlay jp-carousel-light" style="display: none;">
<div class="jp-carousel-container jp-carousel-light">

<div class="jp-carousel-wrap swiper-container jp-carousel-swiper-container jp-carousel-transitions" itemscope="" itemtype="https://schema.org/ImageGallery">
<div class="jp-carousel swiper-wrapper"></div>
<div class="jp-swiper-button-prev swiper-button-prev">
<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
<mask id="maskPrev" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="9" height="12">
<path d="M16.2072 16.59L11.6496 12L16.2072 7.41L14.8041 6L8.8335 12L14.8041 18L16.2072 16.59Z" fill="white"></path>
</mask>
<g mask="url(#maskPrev)">
<rect x="0.579102" width="23.8823" height="24" fill="#FFFFFF"></rect>
</g>
</svg>
</div>
<div class="jp-swiper-button-next swiper-button-next">
<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
<mask id="maskNext" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="8" height="12">
<path d="M8.59814 16.59L13.1557 12L8.59814 7.41L10.0012 6L15.9718 12L10.0012 18L8.59814 16.59Z" fill="white"></path>
</mask>
<g mask="url(#maskNext)">
<rect x="0.34375" width="23.8822" height="24" fill="#FFFFFF"></rect>
</g>
</svg>
</div>
</div>

<div class="jp-carousel-close-hint">
<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
<mask id="maskClose" mask-type="alpha" maskUnits="userSpaceOnUse" x="5" y="5" width="15" height="14">
<path d="M19.3166 6.41L17.9135 5L12.3509 10.59L6.78834 5L5.38525 6.41L10.9478 12L5.38525 17.59L6.78834 19L12.3509 13.41L17.9135 19L19.3166 17.59L13.754 12L19.3166 6.41Z" fill="white"></path>
</mask>
<g mask="url(#maskClose)">
<rect x="0.409668" width="23.8823" height="24" fill="#FFFFFF"></rect>
</g>
</svg>
</div>

<div class="jp-carousel-info">
<div class="jp-carousel-info-footer">
<div class="jp-carousel-pagination-container">
<div class="jp-swiper-pagination swiper-pagination"></div>
<div class="jp-carousel-pagination"></div>
</div>
<div class="jp-carousel-photo-title-container">
<h2 class="jp-carousel-photo-caption"></h2>
</div>
<div class="jp-carousel-photo-icons-container">
<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-info" aria-label="Toggle photo metadata visibility">
<span class="jp-carousel-icon">
<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
<mask id="maskInfo" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
<path fill-rule="evenodd" clip-rule="evenodd" d="M12.7537 2C7.26076 2 2.80273 6.48 2.80273 12C2.80273 17.52 7.26076 22 12.7537 22C18.2466 22 22.7046 17.52 22.7046 12C22.7046 6.48 18.2466 2 12.7537 2ZM11.7586 7V9H13.7488V7H11.7586ZM11.7586 11V17H13.7488V11H11.7586ZM4.79292 12C4.79292 16.41 8.36531 20 12.7537 20C17.142 20 20.7144 16.41 20.7144 12C20.7144 7.59 17.142 4 12.7537 4C8.36531 4 4.79292 7.59 4.79292 12Z" fill="white"></path>
</mask>
<g mask="url(#maskInfo)">
<rect x="0.8125" width="23.8823" height="24" fill="#FFFFFF"></rect>
</g>
</svg>
</span>
</a>
</div>
</div>
<div class="jp-carousel-info-extra">
<div class="jp-carousel-info-content-wrapper">
<div class="jp-carousel-photo-title-container">
<h2 class="jp-carousel-photo-title"></h2>
</div>
<div class="jp-carousel-comments-wrapper">
</div>
<div class="jp-carousel-image-meta">
<div class="jp-carousel-title-and-caption">
<div class="jp-carousel-photo-info">
<h3 class="jp-carousel-caption" itemprop="caption description"></h3>
</div>
<div class="jp-carousel-photo-description"></div>
</div>
<ul class="jp-carousel-image-exif" style="display: none;"></ul>
<a class="jp-carousel-image-download" target="_blank" style="display: none;">
<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
<mask id="mask0" mask-type="alpha" maskUnits="userSpaceOnUse" x="3" y="3" width="19" height="18">
<path fill-rule="evenodd" clip-rule="evenodd" d="M5.84615 5V19H19.7775V12H21.7677V19C21.7677 20.1 20.8721 21 19.7775 21H5.84615C4.74159 21 3.85596 20.1 3.85596 19V5C3.85596 3.9 4.74159 3 5.84615 3H12.8118V5H5.84615ZM14.802 5V3H21.7677V10H19.7775V6.41L9.99569 16.24L8.59261 14.83L18.3744 5H14.802Z" fill="white"></path>
</mask>
<g mask="url(#mask0)">
<rect x="0.870605" width="23.8823" height="24" fill="#FFFFFF"></rect>
</g>
</svg>
<span class="jp-carousel-download-text"></span>
</a>
<div class="jp-carousel-image-map" style="display: none;"></div>
</div>
</div>
</div>
</div>
</div>
</div>
<script>
		window.WPCOM_sharing_counts = {"https:\/\/euromaidanpress.com\/2022\/03\/04\/international-cyberoffensive-gives-russia-a-sip-of-its-own-bitter-medicine\/":160604};
	</script>
<script src="https://static2.euromaidanpress.com/wp-content/plugins/simple-tooltips/zebra_tooltips.js?ver=ac2732b0918a4eecf73796ab1bfda806" id="simple_tooltips_base-js"></script>
<script src="https://static.euromaidanpress.com/wp-content/themes/superblog/functions/js/shortcodes.js?ver=ac2732b0918a4eecf73796ab1bfda806" id="tmnf-shortcodes-js"></script>
<script src="https://euromaidanpress.com/wp-includes/js/dist/vendor/regenerator-runtime.min.js?ver=0.13.9" id="regenerator-runtime-js"></script>
<script src="https://euromaidanpress.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=3.15.0" id="wp-polyfill-js"></script>
<script src="https://euromaidanpress.com/wp-includes/js/dist/hooks.min.js?ver=1e58c8c5a32b2e97491080c5b10dc71c" id="wp-hooks-js"></script>
<script id="wppopups-js-extra">
/* <![CDATA[ */
var wppopups_vars = {"is_admin":"","ajax_url":"https:\/\/euromaidanpress.com\/wp-admin\/admin-ajax.php","pid":"160604","is_front_page":"","is_blog_page":"","is_category":"","site_url":"https:\/\/euromaidanpress.com","is_archive":"","is_search":"","is_singular":"1","is_preview":"","facebook":"","twitter":"","val_required":"This field is required.","val_url":"Please enter a valid URL.","val_email":"Please enter a valid email address.","val_number":"Please enter a valid number.","val_checklimit":"You have exceeded the number of allowed selections: {#}.","val_limit_characters":"{count} of {limit} max characters.","val_limit_words":"{count} of {limit} max words."};
/* ]]> */
</script>
<script src="https://static2.euromaidanpress.com/wp-content/plugins/wp-popups-lite/src/assets/js/wppopups.js?ver=2.1.4.5" id="wppopups-js"></script>
<script id="rtoc_js-js-extra">
/* <![CDATA[ */
var rtocScrollAnimation = {"rtocScrollAnimation":"off"};
var rtocBackButton = {"rtocBackButton":"off"};
var rtocOpenText = {"rtocOpenText":"Open"};
var rtocCloseText = {"rtocCloseText":"Close"};
/* ]]> */
</script>
<script src="https://static2.euromaidanpress.com/wp-content/plugins/rich-table-of-content/js/rtoc_common.js?ver=ac2732b0918a4eecf73796ab1bfda806" id="rtoc_js-js"></script>
<script id="hash_link_scroll_offset-js-extra">
/* <![CDATA[ */
var hlso_offset = {"offset":"70"};
/* ]]> */
</script>
<script src="https://static2.euromaidanpress.com/wp-content/plugins/hash-link-scroll-offset/assets/js/hash-link-scroll-offset.min.js?ver=0.2.0" id="hash_link_scroll_offset-js"></script>
<script src="https://static2.euromaidanpress.com/wp-content/plugins/olevmedia-shortcodes/assets/js/shortcodes.js?fcolevmedia&amp;ver=1.1.9" id="omsc-shortcodes-js"></script>
<script id="ppress-frontend-script-js-extra">
/* <![CDATA[ */
var pp_ajax_form = {"ajaxurl":"https:\/\/euromaidanpress.com\/wp-admin\/admin-ajax.php","confirm_delete":"Are you sure?","deleting_text":"Deleting...","deleting_error":"An error occurred. Please try again.","nonce":"41f0bd5338","disable_ajax_form":"false"};
/* ]]> */
</script>
<script src="https://static2.euromaidanpress.com/wp-content/plugins/wp-user-avatar/assets/js/frontend.min.js?ver=3.2.8" id="ppress-frontend-script-js"></script>
<script src="https://static.euromaidanpress.com/wp-content/themes/superblog/js/superfish.js?ver=ac2732b0918a4eecf73796ab1bfda806" id="superfish-js"></script>
<script src="https://static.euromaidanpress.com/wp-content/themes/superblog/js/jquery.hoverIntent.minified.js?ver=ac2732b0918a4eecf73796ab1bfda806" id="jquery.hoverIntent.minified-js"></script>
<script src="https://static.euromaidanpress.com/wp-content/themes/superblog/js/jquery.prettyPhoto.js?ver=ac2732b0918a4eecf73796ab1bfda806" id="prettyPhoto-js"></script>
<script src="https://static.euromaidanpress.com/wp-content/themes/superblog/js/ownScript.js?ver=ac2732b0918a4eecf73796ab1bfda806" id="ownScript-js"></script>
<script src="https://static.euromaidanpress.com/wp-content/themes/superblog/js/mobile.js?ver=ac2732b0918a4eecf73796ab1bfda806" id="mobile-js"></script>
<script src="https://static.euromaidanpress.com/wp-content/themes/superblog/js/jquery.flexslider-min.js?ver=ac2732b0918a4eecf73796ab1bfda806" id="jquery.flexslider-min-js"></script>
<script src="https://static.euromaidanpress.com/wp-content/themes/superblog/js/jquery.flexslider.start.single.js?ver=ac2732b0918a4eecf73796ab1bfda806" id="jquery.flexslider.start.single-js"></script>
<script src="https://static2.euromaidanpress.com/wp-content/plugins/easy-fancybox/js/jquery.fancybox.min.js?ver=1.3.24" id="jquery-fancybox-js"></script>
<script id="jquery-fancybox-js-after">
var fb_timeout, fb_opts={'overlayShow':true,'hideOnOverlayClick':true,'showCloseButton':true,'padding':0,'margin':20,'centerOnScroll':false,'enableEscapeButton':true,'autoScale':true };
if(typeof easy_fancybox_handler==='undefined'){
var easy_fancybox_handler=function(){
jQuery('.nofancybox,a.wp-block-file__button,a.pin-it-button,a[href*="pinterest.com/pin/create"],a[href*="facebook.com/share"],a[href*="twitter.com/share"]').addClass('nolightbox');
/* Inline */
jQuery('a.fancybox-inline,area.fancybox-inline,li.fancybox-inline a').each(function(){jQuery(this).fancybox(jQuery.extend({},fb_opts,{'type':'inline','autoDimensions':true,'scrolling':'no','easingIn':'easeOutBack','easingOut':'easeInBack','opacity':false,'hideOnContentClick':false,'titleShow':false}))});
/* PDF */
jQuery('a[href*=".pdf"],area[href*=".pdf"],a[href*=".PDF"],area[href*=".PDF"]').not('.nolightbox,li.nolightbox>a').addClass('fancybox-pdf');
jQuery('a.fancybox-pdf,area.fancybox-pdf,li.fancybox-pdf a').each(function(){jQuery(this).fancybox(jQuery.extend({},fb_opts,{'type':'iframe','width':'90%','height':'90%','padding':10,'titleShow':false,'titlePosition':'float','titleFromAlt':true,'autoDimensions':false,'scrolling':'no'}))});
/* YouTube */
jQuery('a[href*="youtu.be/"],area[href*="youtu.be/"],a[href*="youtube.com/"],area[href*="youtube.com/"]').filter(function(){return this.href.match(/\/(?:youtu\.be|watch\?|embed\/)/);}).not('.nolightbox,li.nolightbox>a').addClass('fancybox-youtube');
jQuery('a.fancybox-youtube,area.fancybox-youtube,li.fancybox-youtube a').each(function(){jQuery(this).fancybox(jQuery.extend({},fb_opts,{'type':'iframe','width':640,'height':360,'keepRatio':1,'titleShow':false,'titlePosition':'float','titleFromAlt':true,'onStart':function(a,i,o){var splitOn=a[i].href.indexOf("?");var urlParms=(splitOn>-1)?a[i].href.substring(splitOn):"";o.allowfullscreen=(urlParms.indexOf("fs=0")>-1)?false:true;o.href=a[i].href.replace(/https?:\/\/(?:www\.)?youtu(?:\.be\/([^\?]+)\??|be\.com\/watch\?(.*(?=v=))v=([^&]+))(.*)/gi,"https://www.youtube.com/embed/$1$3?$2$4&autoplay=1");}}))});
/* Vimeo */
jQuery('a[href*="vimeo.com/"],area[href*="vimeo.com/"]').filter(function(){return this.href.match(/\/(?:[0-9]+|video\/)/);}).not('.nolightbox,li.nolightbox>a').addClass('fancybox-vimeo');
jQuery('a.fancybox-vimeo,area.fancybox-vimeo,li.fancybox-vimeo a').each(function(){jQuery(this).fancybox(jQuery.extend({},fb_opts,{'type':'iframe','width':500,'height':281,'keepRatio':1,'titleShow':false,'titlePosition':'float','titleFromAlt':true,'onStart':function(a,i,o){var splitOn=a[i].href.indexOf("?");var urlParms=(splitOn>-1)?a[i].href.substring(splitOn):"";o.allowfullscreen=(urlParms.indexOf("fullscreen=0")>-1)?false:true;o.href=a[i].href.replace(/https?:\/\/(?:www\.)?vimeo\.com\/([0-9]+)\??(.*)/gi,"https://player.vimeo.com/video/$1?$2&autoplay=1");}}))});
/* iFrame */
jQuery('a.fancybox-iframe,area.fancybox-iframe,li.fancybox-iframe a').each(function(){jQuery(this).fancybox(jQuery.extend({},fb_opts,{'type':'iframe','width':'95%','height':'95%','padding':0,'titleShow':false,'titlePosition':'float','titleFromAlt':true,'allowfullscreen':false}))});};
jQuery('a.fancybox-close').on('click',function(e){e.preventDefault();jQuery.fancybox.close()});
};
var easy_fancybox_auto=function(){setTimeout(function(){jQuery('#fancybox-auto').trigger('click')},0);};
jQuery(easy_fancybox_handler);jQuery(document).on('post-load',easy_fancybox_handler);
jQuery(easy_fancybox_auto);
</script>
<script id="facebook-jssdk-js-extra">
/* <![CDATA[ */
var FB_WP=FB_WP||{};FB_WP.queue={_methods:[],flushed:false,add:function(fn){FB_WP.queue.flushed?fn():FB_WP.queue._methods.push(fn)},flush:function(){for(var fn;fn=FB_WP.queue._methods.shift();){fn()}FB_WP.queue.flushed=true}};window.fbAsyncInit=function(){FB.init({"xfbml":true,"appId":"1395391370748120"});if(FB_WP && FB_WP.queue && FB_WP.queue.flush){FB_WP.queue.flush()}}
/* ]]> */
</script>
<script>(function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(d.getElementById(id)){return}js=d.createElement(s);js.id=id;js.src="https:\/\/connect.facebook.net\/en_US\/all.js";fjs.parentNode.insertBefore(js,fjs)}(document,"script","facebook-jssdk"));</script>
<script defer="" src="https://static2.euromaidanpress.com/wp-content/plugins/youtube-embed-plus/scripts/fitvids.min.js?ver=14.0.1.4" id="__ytprefsfitvids__-js"></script>
<script id="jetpack-carousel-js-extra">
/* <![CDATA[ */
var jetpackSwiperLibraryPath = {"url":"https:\/\/static2.euromaidanpress.com\/wp-content\/plugins\/jetpack\/_inc\/build\/carousel\/swiper-bundle.min.js"};
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/euromaidanpress.com\/wp-admin\/admin-ajax.php","nonce":"97caac1f83","display_exif":"0","display_comments":"0","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"white","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"1","require_name_email":"1","login_url":"https:\/\/euromaidanpress.com\/wp-login.php?redirect_to=https%3A%2F%2Feuromaidanpress.com%2F2022%2F03%2F04%2Finternational-cyberoffensive-gives-russia-a-sip-of-its-own-bitter-medicine%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"]};
/* ]]> */
</script>
<script src="https://static2.euromaidanpress.com/wp-content/plugins/jetpack/_inc/build/carousel/jetpack-carousel.min.js?ver=10.7" id="jetpack-carousel-js"></script>
<script defer="" src="https://static2.euromaidanpress.com/wp-content/plugins/mailchimp-for-wp/assets/js/forms.js?ver=4.8.6" id="mc4wp-forms-api-js"></script>
<script id="sharing-js-js-extra">
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script src="https://static2.euromaidanpress.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=10.7" id="sharing-js-js"></script>
<script id="sharing-js-js-after">
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-linkedin' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-linkedin' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-tumblr' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-tumblr' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-pocket' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-pocket' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcompocket', 'menubar=1,resizable=1,width=450,height=450' );
						return false;
					}
				} );
			} )();
</script>
<div id="fb-root"></div><script id="slb_context">/* <![CDATA[ */if ( !!window.jQuery ) {(function($){$(document).ready(function(){if ( !!window.SLB ) { {$.extend(SLB, {"context":["public","user_guest"]});} }})})(jQuery);}/* ]]> */</script>
<script>
                    jQuery(function() {
                                                
                        jQuery(".tooltips img").closest(".tooltips").css("display", "inline-block");
                    
                        new jQuery.Zebra_Tooltips(jQuery('.tooltips').not('.custom_m_bubble'), {
                            'background_color':     '#000000',
                            'color':				'#ffffff',
                            'max_width':  250,
                            'opacity':    .95, 
                            'position':    'center'
                        });
                        
                                            
                    });
                </script>
<script src="https://stats.wp.com/e-202209.js" defer=""></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.7',blog:'135706341',post:'160604',tz:'2',srv:'euromaidanpress.com'} ]);
	_stq.push([ 'clickTrackerInit', '135706341', '160604' ]);
</script>
<script>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</script>
<script>
//replace thumbnails with divs so that they weren't squeezed for deleted image sizes, uncomment if correspondent image displayed in wrong proportions"
//img2div('size-related');
//img2div('attachment-blog-big');
//img2div(' jp-relatedposts-post-img');


function img2div(css_class){
	var matches = document.getElementsByClassName(css_class);
	for (var i=0; i<matches.length; i++) {
	  if(matches[i].src){
	  	var div = document.createElement('div'),
	  		styles = window.getComputedStyle(matches[i], ""),
	  		needed = [ 'width', 'height'], 
	  		tmp = "";
	  	for(var j = matches[i].attributes.length - 1; j > -1; --j){
	  		var attr = matches[i].attributes[j];
	  		if(attr.name != 'src') div.setAttribute(attr.name, attr.value);
	  		}
	  	for(var z=0; z< needed.length;z++){
	  		tmp += needed[z] + ': ' + styles[needed[z]] + '; ';
	  		}
	  	URL = matches[i].src;
	  	div.style = "background:url('"+URL+"') center no-repeat; background-size:cover; " + tmp;
	  	matches[i].parentNode.replaceChild(div, matches[i]);
	  	}
	}
}
</script>
<pre id="theend" style="width:0;height:0"></pre>
<span class="ezoic"></span>
<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('/detroitchicago/edmonton.webp', '//g.ezoic.net/detroitchicago/edmonton.webp?a=a&cb=3&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('/porpoiseant/jellyfish.webp', '//g.ezoic.net/porpoiseant/jellyfish.webp?a=a&cb=3&shcb=34', false, [], true, false, false, false);
</script>
<script>var _audins_dom="euromaidanpress_com",_audins_did=6354;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=195-3");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.euromaidanpress_com,DomainId.6354" border="0" height="1" width="1" alt="Quantcast"/></div></noscript>
<script type="text/javascript" data-cfasync="false"></script>
<script>__ez.queue.addFile('/tardisrocinante/vitals.js', '//g.ezoic.net/tardisrocinante/vitals.js?gcb=3&cb=3', false, ['/detroitchicago/minneapolis.js'], true, false, true, false);</script><script type="text/javascript">(function(){window['__CF$cv$params']={r:'6e6b9185abb85818',m:'dNDSRnhg7xLDxdLjqn62Z.Yudq2WNAvHSOkwWzMY0eI-1646406939-0-AdzZmyv5178Bi1hhYHsJsqTd7FIo5w+ekHBwVrb/WIaQIt+cJTNnddGFBKNxwci4MGZJ9PDii2BrzNnmIN8GqI39Pg21ZW70l3vO+b6McTRdS8KUaBwIMAXtn1RyiciY178DLgqZdm3I3Lh15Y3SfeWdJZPqdA1dyQZSOQ+lNFsCUwZEEDMEcrZgCKA76hKB3HhLaFyLGKuFLhKkqEsRMBGl/H8+/pUAZ7MEFoBsDWlV',s:[0xc0078202f5,0xca04a8c282],u:'/cdn-cgi/challenge-platform/h/g'}})();</script></body></html>